Allow -nogfx boards to start the homescreen 33/25933/3
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 20 Jan 2021 17:35:25 +0000 (18:35 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 26 Jan 2021 16:48:20 +0000 (16:48 +0000)
This allows to produce working images without restricted licenses.
Software rendering will be slow and screen updates take a while.

v2: adapted to use WESTON_USE_PIXMAN

Bug-AGL: SPEC-3774
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: Iaea1985da48985dfe223471a86b04d8921cc8d7a
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25933
Reviewed-by: Scott Murray <scott.murray@konsulko.com>
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>

meta-agl-bsp/conf/include/agl_h3-salvator-x-nogfx.inc
meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc
meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc

index c120263..3bc9f95 100644 (file)
@@ -8,3 +8,7 @@ DTB_SUFFIX = "r8a7795-salvator-xs"
 BBMASK += "gles-user-module|kernel-module-gles|wayland-kms|libgbm"
 # Mask MMP recipes
 BBMASK += "kernel-module-uvcs-drv|omx-user-module"
+
+# do use software rendering to display the compositor
+# used for images w/o binary-only driver
+WESTON_USE_PIXMAN = "1"
index 70bc68b..25dfb04 100644 (file)
@@ -11,3 +11,7 @@ BBMASK += "kernel-module-uvcs-drv|omx-user-module"
 
 # Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
 BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
+
+# do use software rendering to display the compositor
+# used for images w/o binary-only driver
+WESTON_USE_PIXMAN = "1"
index 28360fc..48fe12e 100644 (file)
@@ -14,3 +14,7 @@ IMAGE_INSTALL_append = "${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen-base x
 
 # Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
 BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
+
+# do use software rendering to display the compositor
+# used for images w/o binary-only driver
+WESTON_USE_PIXMAN = "1"