Use new weston-ini-conf scheme and remove old per-machine files 85/28985/3
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 5 Jun 2023 11:56:35 +0000 (13:56 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 5 Jun 2023 20:48:24 +0000 (20:48 +0000)
The previous commit used an old file. Use the new generated version.

Bug-AGL: SPEC-4822
Change-Id: Ic1b7018ce2840332c0e051101ce854b90f96ecae
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28985
Tested-by: Jenkins Job builder account
meta-agl-bsp/conf/include/agl_raspberrypi4.inc
meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend [deleted file]
meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/dsi.cfg [deleted file]
meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-dual.cfg [deleted file]
meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-2-0.cfg [new file with mode: 0644]
meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-2-180.cfg [new file with mode: 0644]
meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-2-270.cfg [new file with mode: 0644]
meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-2-90.cfg [new file with mode: 0644]

index 3fdc68b..7fd878d 100644 (file)
@@ -29,3 +29,6 @@ IMAGE_INSTALL:append = " ${@bb.utils.contains('AGL_XEN_WANTED', '1', 'xen-tools
 
 # Add xen-raspberry binary to boot files
 IMAGE_BOOT_FILES:append = " ${@bb.utils.contains('AGL_XEN_WANTED','1', 'xen-${MACHINE}', '',d)}"
+
+#DISPLAY CONFIGURATION
+WESTON_DISPLAYS:raspberrypi4 = " hdmi-a-1-90 hdmi-a-2-90"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
deleted file mode 100644 (file)
index 9e50a75..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-FILESEXTRAPATHS:prepend:raspberrypi := "${THISDIR}/${PN}:"
-
-# OLD DSI config
-#SRC_URI:append:raspberrypi = " file://dsi.cfg"
-
-# two hdmi ports
-SRC_URI:append:raspberrypi = " file://hdmi-dual.cfg"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/dsi.cfg b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/dsi.cfg
deleted file mode 100644 (file)
index ed6a4ed..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-# Support the Raspberry Pi Foundation 7" tablet which uses the DSI connector
-# rather than HDMI.
-[output]
-name=DSI-1
-transform=rotate-90
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-dual.cfg b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-dual.cfg
deleted file mode 100644 (file)
index 61d1362..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-# Support the Raspberry Pi Foundation 7" tablet which uses the DSI connector
-# rather than HDMI.
-[output]
-name=HDMI-A-1
-transform=rotate-90
-
-[output]
-name=HDMI-A-2
-transform=rotate-90
index f7b281e..2f5185d 100644 (file)
@@ -9,6 +9,10 @@ SRC_URI = " \
        file://hdmi-a-1-90.cfg \
        file://hdmi-a-1-180.cfg \
        file://hdmi-a-1-270.cfg \
+       file://hdmi-a-2-0.cfg \
+       file://hdmi-a-2-90.cfg \
+       file://hdmi-a-2-180.cfg \
+       file://hdmi-a-2-270.cfg \
        file://remote-output.cfg.in \
        file://transmitter-output.cfg.in \
        file://virtual-0.cfg \
@@ -73,6 +77,9 @@ do_compile() {
         if echo $F | grep '^hdmi-a-1-\(90\|270\)$'; then
             F="hdmi-a-1-0"
             INVF="hdmi-a-1-180"
+        elif echo $F | grep '^hdmi-a-2-\(90\|270\)$'; then
+            F="hdmi-a-2-0"
+            INVF="hdmi-a-2-180"
         elif echo $F | grep '^virtual-90$'; then
             F="virtual-0"
             INVF="virtual-180"
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-2-0.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-2-0.cfg
new file mode 100644 (file)
index 0000000..4d5d51c
--- /dev/null
@@ -0,0 +1,5 @@
+# A display is connected to HDMI-A-1 and needs to be rotated 90 degrees
+# to have a proper orientation of the homescreen.  For example, the 'eGalax'
+# display used in some instances.
+[output]
+name=HDMI-A-2
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-2-180.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-2-180.cfg
new file mode 100644 (file)
index 0000000..ffdc5fe
--- /dev/null
@@ -0,0 +1,6 @@
+# A display is connected to HDMI-A-1 and needs to be rotated 90 degrees
+# to have a proper orientation of the homescreen.  For example, the 'eGalax'
+# display used in some instances.
+[output]
+name=HDMI-A-2
+transform=rotate-180
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-2-270.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-2-270.cfg
new file mode 100644 (file)
index 0000000..76fc77a
--- /dev/null
@@ -0,0 +1,6 @@
+# A display is connected to HDMI-A-1 and needs to be rotated 90 degrees
+# to have a proper orientation of the homescreen.  For example, the 'eGalax'
+# display used in some instances.
+[output]
+name=HDMI-A-2
+transform=rotate-270
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-2-90.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-2-90.cfg
new file mode 100644 (file)
index 0000000..9172a1c
--- /dev/null
@@ -0,0 +1,6 @@
+# A display is connected to HDMI-A-1 and needs to be rotated 90 degrees
+# to have a proper orientation of the homescreen.  For example, the 'eGalax'
+# display used in some instances.
+[output]
+name=HDMI-A-2
+transform=rotate-90