Update github.com git:// SRC_URIs 79/26779/2 12.90.1 marlin/12.90.1 marlin_12.90.1
authorScott Murray <scott.murray@konsulko.com>
Tue, 2 Nov 2021 23:15:07 +0000 (19:15 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 3 Nov 2021 17:46:25 +0000 (17:46 +0000)
GitHub is dropping unauthenticated git protocol access in
January 2022, per:

https://github.blog/2021-09-01-improving-git-protocol-security-github/#no-more-unauthenticated-git

While a workaround in the BitBake git fetcher is forthcoming, not
specifying protocol=https for github.com git:// SRC_URIs will start
resulting in warnings in Yocto 3.5/Kirkstone.  To ease our upgrade
path, go ahead and update our affected SRC_URIs.  Note that this has
been done by running the scripts/contrib/convert-srcuri.py script
from latest poky, which also makes git branch specification explicit
since the git fetcher is likely to require that in the future due
to widespread switches from master to main branches.

Bug-AGL: SPEC-4126

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I1b5003a79de5283f88bb51f2decadbabeaff8ed5
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26779
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2021.07.inc
meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-examples_git.bb
meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-test_git.bb
meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-user-app-template_git.bb
meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb
meta-agl-core/recipes-graphics/wayland/waltham_git.bb
meta-app-framework/recipes-security/audit/audit_2.8.5.bb
meta-app-framework/recipes-security/security-manager/security-manager_git.bb

index 0b80886..a471928 100644 (file)
@@ -5,7 +5,7 @@ LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=acc7a1bf87c055789657b148939e4b40"
 
 SRC_URI = "\
-    git://github.com/aws/aws-iot-device-sdk-embedded-C.git;protocol=https \
+    git://github.com/aws/aws-iot-device-sdk-embedded-C.git;protocol=https;branch=master \
     file://Makefile.aws \
     file://aws_iot_config.h \
     file://awsiotsdk.pc \
index abf7474..fe3f656 100644 (file)
@@ -1,3 +1,3 @@
-SRC_URI = "git://git.denx.de/u-boot.git"
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
 SRCREV = "840658b093976390e9537724f802281c9c8439f5"
 LIC_FILES_CHKSUM = "file://Licenses/README;md5=5a7450c57ffe5ae63fd732446b988025"
index 6528f30..9d06df2 100644 (file)
@@ -13,7 +13,7 @@ PV = "3.6.0+git${SRCPV}"
 SRCREV = "292da2fd8db0176e0e96989268c63ef9ab910a6c"
 
 SRC_URI = " \
-    git://github.com/linaro-swg/optee_examples;branch=master;name=master \
+    git://github.com/linaro-swg/optee_examples;branch=master;name=master;protocol=https \
     file://0001-secure_storage-ta-Add-a-missing-include-file.patch \
 "
 
index 153bfe6..2feda0e 100644 (file)
@@ -12,7 +12,7 @@ PV = "3.1.0+git${SRCPV}"
 SRCREV = "45218eb59b006ad20cc7610904f291dd85157a43"
 
 SRC_URI = " \
-    git://github.com/OP-TEE/optee_test.git;branch=master;name=master \
+    git://github.com/OP-TEE/optee_test.git;branch=master;name=master;protocol=https \
     file://optee_xtest_fix.diff \
 "
 
index 10d8bdc..1577f8f 100644 (file)
@@ -12,7 +12,7 @@ PV = "0.1+git${SRCPV}"
 SRCREV = "0.1"
 
 SRC_URI = " \
-    git://github.com/iotbzh/optee_user_app_template;branch=master \
+    git://github.com/iotbzh/optee_user_app_template;branch=master;protocol=https \
 "
 
 COMPATIBLE_MACHINE = "(salvator-x|h3ulcb|m3ulcb|m3nulcb|ebisu)"
index 903ebc6..d4ef916 100644 (file)
@@ -9,7 +9,7 @@ DEPENDS = "dbus ncurses connman json-c"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=8c16666ae6c159876a0ba63099614381"
 
-SRC_URI = "git://gitlab.com/iotbzh/connman-json-client.git;protocol=https \
+SRC_URI = "git://gitlab.com/iotbzh/connman-json-client.git;protocol=https;branch=master \
            file://stdbool-fixes.patch"
 SRCREV = "2b0f93ec9518c978c04807fe52e95315d6d80e6b"
 
index 2a2592d..da092a5 100644 (file)
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = " \
   file://LICENSE;md5=e8ad01a5182f2c1b3a2640e9ea268264 \
 "
 SRCREV = "1de58c3ff746ddaba7584d760c5454243723d3ca"
-SRC_URI = "git://github.com/wmizuno/waltham.git \
+SRC_URI = "git://github.com/wmizuno/waltham.git;branch=master;protocol=https \
           "
 S = "${WORKDIR}/git"
 
index 19cc688..618e5e8 100644 (file)
@@ -7,7 +7,7 @@ SECTION = "base"
 LICENSE = "GPLv2+ & LGPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 
-SRC_URI = "git://github.com/linux-audit/${BPN}-userspace.git;branch=2.8_maintenance \
+SRC_URI = "git://github.com/linux-audit/${BPN}-userspace.git;branch=2.8_maintenance;protocol=https \
            file://Add-substitue-functions-for-strndupa-rawmemchr.patch \
            file://Fixed-swig-host-contamination-issue.patch \
            file://0001-lib-i386_table.h-add-new-syscall.patch \
index b349735..95ae69f 100644 (file)
@@ -2,7 +2,7 @@ require security-manager.inc
 
 PV = "1.0.2+git${SRCPV}"
 SRCREV = "860305a595d681d650024ad07b3b0977e1fcb0a6"
-SRC_URI += "git://github.com/Samsung/security-manager.git"
+SRC_URI += "git://github.com/Samsung/security-manager.git;branch=master;protocol=https"
 S = "${WORKDIR}/git"
 
 SRC_URI += " \