interbench: Integrate JTA patches 67/5467/3
authorYannick Gicquel <yannick.gicquel@iot.bzh>
Thu, 31 Mar 2016 15:06:29 +0000 (17:06 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 10 Apr 2016 07:52:23 +0000 (07:52 +0000)
Change-Id: If5977aa44747fefcec6fbc50a2ad214d636bf17f
Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
meta-ivi-common/recipes-test/interbench/files/interbench.c.patch [new file with mode: 0755]
meta-ivi-common/recipes-test/interbench/interbench_0.31.bb

diff --git a/meta-ivi-common/recipes-test/interbench/files/interbench.c.patch b/meta-ivi-common/recipes-test/interbench/files/interbench.c.patch
new file mode 100755 (executable)
index 0000000..c882739
--- /dev/null
@@ -0,0 +1,68 @@
+--- interbench.c.orig  2009-10-30 23:14:59.000000000 -0500
++++ interbench.c       2012-07-10 19:06:00.000000000 -0500
+@@ -71,6 +71,7 @@ struct user_data {
+       char datestamp[13];
+       FILE *logfile;
+ } ud = {
++      .ram = 0,
+       .duration = 30,
+       .cpu_load = 4,
+       .log = 1,
+@@ -652,6 +653,8 @@ void emulate_write(struct thread *th)
+                       terminal_error("fopen");
+               if (stat(name, &statbuf) == -1)
+                       terminal_fileopen_error(fp, "stat");
++              if (statbuf.st_blksize < MIN_BLK_SIZE)
++                      statbuf.st_blksize = MIN_BLK_SIZE;
+               for (i = 0 ; i < mem; i++) {
+                       if (fwrite(buf, statbuf.st_blksize, 1, fp) != 1)
+                               terminal_fileopen_error(fp, "fwrite");
+@@ -1136,14 +1139,17 @@ void get_ram(void)
+       if(!(meminfo = fopen("/proc/meminfo", "r")))
+               terminal_error("fopen");
+-      ud.ram = ud.swap = 0;
+-      while( !feof(meminfo) && !fscanf(meminfo, "MemTotal: %lu kB", &ud.ram) )
+-            fgets(aux,sizeof(aux),meminfo);
++      if (!ud.ram)
++      {
++          while( !feof(meminfo) && !fscanf(meminfo, "MemTotal: %lu kB", &ud.ram) )
++              fgets(aux,sizeof(aux),meminfo);
++      }
++      ud.swap = 0;
+       while( !feof(meminfo) && !fscanf(meminfo, "SwapTotal: %lu kB", &ud.swap) )
+             fgets(aux,sizeof(aux),meminfo);
+       if (fclose(meminfo) == -1)
+               terminal_error("fclose");
+-
++ 
+       if( !ud.ram || !ud.swap ) {
+               unsigned long i;
+               fprintf(stderr, "\nCould not get memory or swap size. ");
+@@ -1399,6 +1405,7 @@ void usage(void)
+       fprintf(stderr, "\t[-h]\n\n");
+       fprintf(stderr, " -l\tUse <int> loops per sec (default: use saved benchmark)\n");
+       fprintf(stderr, " -L\tUse cpu load of <int> with burn load (default: 4)\n");
++      fprintf(stderr, " -M\tForce RAM size to <int>. Useful when disk is smaller than RAM.\n");
+       fprintf(stderr, " -t\tSeconds to run each benchmark (default: 30)\n");
+       fprintf(stderr, " -B\tNice the benchmarked thread to <int> (default: 0)\n");
+       fprintf(stderr, " -N\tNice the load thread to <int> (default: 0)\n");
+@@ -1482,7 +1489,7 @@ int main(int argc, char **argv)
+               terminal_error("signal");
+ #endif
+-      while ((q = getopt(argc, argv, "hl:L:B:N:ut:bcnrC:I:m:w:x:W:X:")) != -1) {
++      while ((q = getopt(argc, argv, "hl:L:M:B:N:ut:bcnrC:I:m:w:x:W:X:")) != -1) {
+               switch (q) {
+                       case 'h':
+                               usage();
+@@ -1496,6 +1503,9 @@ int main(int argc, char **argv)
+                       case 'L':
+                               ud.cpu_load = atoi(optarg);
+                               break;
++                      case 'M':
++                              ud.ram = atoi(optarg);
++                              break;
+                       case 'B':
+                               ud.bench_nice = atoi(optarg);
+                               break;
index eca0e85..80a717c 100644 (file)
@@ -4,6 +4,8 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
 SRC_URI = "http://ck.kolivas.org/apps/interbench/interbench-${PV}.tar.bz2"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
 SRC_URI = "http://ck.kolivas.org/apps/interbench/interbench-${PV}.tar.bz2"
 
+SRC_URI += "file://interbench.c.patch;striplevel=0"
+
 inherit autotools
 
 B = "${S}"
 inherit autotools
 
 B = "${S}"