waltham: Drop waltham support 05/28805/4
authorMarius Vlad <marius.vlad@collabora.com>
Fri, 5 May 2023 08:44:16 +0000 (11:44 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 8 May 2023 20:15:48 +0000 (20:15 +0000)
Given than we don't really have any users and more importantly no
maintainers it would be best to remove Waltham support entirely from
the tree. The AGL compositor will shortly follow-up to remove supporting
code.

Bug-AGL: SPEC-4669
Change-Id: I4df495bb873d70f380dcc09cb083686f11f0b2e2
Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28805
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
14 files changed:
meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
meta-agl-core/recipes-graphics/wayland/waltham-transmitter-plugin.bb [deleted file]
meta-agl-core/recipes-graphics/wayland/waltham/0001-Use-python3-instead-of-2.patch [deleted file]
meta-agl-core/recipes-graphics/wayland/waltham/0001-waltham-Fix-compile-build-error.patch [deleted file]
meta-agl-core/recipes-graphics/wayland/waltham/0002-commandxml-Add-support-wthp_app_id-interface.patch [deleted file]
meta-agl-core/recipes-graphics/wayland/waltham_%.bbappend [deleted file]
meta-agl-core/recipes-graphics/wayland/waltham_git.bb [deleted file]
meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bbappend
meta-agl-core/recipes-graphics/wayland/weston/0001-libweston-Migrate-weston_seat_init-release-to-public.patch [deleted file]
meta-agl-core/recipes-graphics/wayland/weston_10.0_aglcore.inc
meta-agl-core/recipes-platform/packagegroups/packagegroup-agl-profile-graphical.bb
templates/feature/agl-weston-waltham-remoting/50_local.conf.inc [deleted file]
templates/feature/agl-weston-waltham-remoting/README_feature_agl-weston-waltham-remoting.md [deleted file]
templates/feature/agl-weston-waltham-remoting/included.dep [deleted file]

index 948305d..3e6a8fe 100644 (file)
@@ -8,8 +8,7 @@ SECTION = "x11"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
 
-DEPENDS = "wayland wayland-protocols wayland-native weston \
-          ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
+DEPENDS = "wayland wayland-protocols wayland-native weston"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "4e4624dee9850b4a4e590dd0f0f2b3173bded085"
@@ -43,7 +42,6 @@ RDEPENDS:${PN} += " \
     agl-compositor-init \
     xkeyboard-config \
     ${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
-    ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)} \
 "
 
 FILES:${PN}-dev += " \
diff --git a/meta-agl-core/recipes-graphics/wayland/waltham-transmitter-plugin.bb b/meta-agl-core/recipes-graphics/wayland/waltham-transmitter-plugin.bb
deleted file mode 100644 (file)
index 734fadf..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-DESCRIPTION = "Waltham transmitter is a libweston plug-in that adds support for receiving input events from a surface streamed on a remote output"
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/src/waltham-transmitter-plugin.git"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=f21c9af4de068fb53b83f0b37d262ec3"
-
-DEPENDS += "wayland wayland-native waltham weston"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/waltham-transmitter-plugin.git;protocol=https;branch=${AGL_BRANCH}"
-AGL_BRANCH:aglnext = "next"
-SRCREV = "d64b99a999fcc17322393782fe802122fd963ced"
-SRCREV:aglnext = "${AUTOREV}"
-
-S = "${WORKDIR}/git"
-
-inherit meson pkgconfig python3native
-
-FILES:${PN} += "${libdir}/*"
-FILES:${PN} += "${bindir}/*"
diff --git a/meta-agl-core/recipes-graphics/wayland/waltham/0001-Use-python3-instead-of-2.patch b/meta-agl-core/recipes-graphics/wayland/waltham/0001-Use-python3-instead-of-2.patch
deleted file mode 100644 (file)
index 32c2df3..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-From 6ecdf10a10929164f3cbdb754ae91d27576e5036 Mon Sep 17 00:00:00 2001
-From: Marius Vlad <marius.vlad@collabora.com>
-Date: Fri, 16 Oct 2020 18:57:38 +0300
-Subject: [PATCH] Use python3 instead of 2
-
-Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
----
- configure.ac | 2 +-
- tools/gen.py | 6 +++---
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 5f65a6b..94b8644 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -32,7 +32,7 @@ AC_SUBST(VERSION_INFO)
- # Check for programs
- AC_PROG_CC
- AC_PROG_CC_STDC
--AC_CHECK_PROGS([PYTHON2], [python2 python])
-+AC_CHECK_PROGS([PYTHON3], [python3 python])
- PKG_PROG_PKG_CONFIG()
- AC_ARG_ENABLE(gprof,
-diff --git a/tools/gen.py b/tools/gen.py
-index 19e8baa..64c5870 100755
---- a/tools/gen.py
-+++ b/tools/gen.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2
-+#!/usr/bin/env python3
- # -*- coding: utf-8 -*-
- # Copyright © 2013-2014 Collabora, Ltd.
-@@ -562,11 +562,11 @@ try:
-     opts, args = getopt.getopt(sys.argv[1:], "hp:i:o:t:m:",
-                                ["preamble=", "input=", "output=", "type=", "mode="])
- except getopt.GetoptError:
--    print 'gen.py -p <preamblefile> -i <inputfile> -o <outputfile> -t <type> -m <mode>'
-+    print('gen.py -p <preamblefile> -i <inputfile> -o <outputfile> -t <type> -m <mode>')
-     sys.exit(2)
- for opt, arg in opts:
-     if opt == '-h':
--        print 'gen.py -p <preamblefile> -i <inputfile> -o <outputfile> -t <type> -m <mode>'
-+        print('gen.py -p <preamblefile> -i <inputfile> -o <outputfile> -t <type> -m <mode>')
-         sys.exit()
-     elif opt in ("-p", "--preamble"):
-         preamble_files.append(arg)
--- 
-2.28.0
-
diff --git a/meta-agl-core/recipes-graphics/wayland/waltham/0001-waltham-Fix-compile-build-error.patch b/meta-agl-core/recipes-graphics/wayland/waltham/0001-waltham-Fix-compile-build-error.patch
deleted file mode 100644 (file)
index 354bcbc..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-From cc87dddc2cdc0c20b053e3da1197efd671b4f50c Mon Sep 17 00:00:00 2001
-From: Marius Vlad <marius.vlad@collabora.com>
-Date: Wed, 23 Sep 2020 22:33:50 +0300
-Subject: [PATCH 1/2] waltham: Fix compile build error
-
-Newer compilers will complain about the fact debug_message is declared
-multiple times:
-
-multiple definition of `debug_message';
-.libs/marshaller.o:/home/mvlad/src/native-agl-weston8/waltham/waltham/src/waltham/marshaller_log.h:35:
-first defined here multiple definition of `debug_message';
-.libs/marshaller.o:/home/mvlad/src/native-agl-weston8/waltham/waltham/src/waltham/marshaller_log.h:35:
-first defined here /usr/bin/ld:
-.libs/client-serialice.o:/home/mvlad/src/native-agl-weston8/waltham/waltham/src/waltham/marshaller_log.h:35:
-multiple definition of `debug_message';
-.libs/marshaller.o:/home/mvlad/src/native-agl-weston8/waltham/waltham/src/waltham/marshaller_log.h:35:
-first defined here
-
-Bug-AGL: SPEC-3649
-
-Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
----
- src/waltham/marshaller_log.h | 2 +-
- src/waltham/waltham-util.c   | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/waltham/marshaller_log.h b/src/waltham/marshaller_log.h
-index 8254914..ffa87c1 100644
---- a/src/waltham/marshaller_log.h
-+++ b/src/waltham/marshaller_log.h
-@@ -32,7 +32,7 @@
- /* Comment/uncomment to disable/enable debugging log */
- #define DEBUG
- //#define PROFILE
--int debug_message;
-+extern int debug_message;
- #ifdef DEBUG
- static inline void DEBUG_STAMP (void) {
-diff --git a/src/waltham/waltham-util.c b/src/waltham/waltham-util.c
-index 410b114..8f898f8 100644
---- a/src/waltham/waltham-util.c
-+++ b/src/waltham/waltham-util.c
-@@ -34,7 +34,7 @@
- #include "waltham-connection.h"
- #include "waltham-private.h"
--int debug_message;
-+extern int debug_message;
- static void
- wth_pfx_print(const char *pfx, const char *fmt, va_list argp)
--- 
-2.28.0
-
diff --git a/meta-agl-core/recipes-graphics/wayland/waltham/0002-commandxml-Add-support-wthp_app_id-interface.patch b/meta-agl-core/recipes-graphics/wayland/waltham/0002-commandxml-Add-support-wthp_app_id-interface.patch
deleted file mode 100644 (file)
index 5aefb92..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-From d30005429fe92daa14151c2a6175d5cf19506cac Mon Sep 17 00:00:00 2001
-From: Marius Vlad <marius.vlad@collabora.com>
-Date: Wed, 7 Oct 2020 16:36:38 +0300
-Subject: [PATCH 2/2] commandxml: Add support wthp_app_id interface
-
-With it, we hang off the app_id which we can use to pass it to the
-receiver side.
-
-Bug-AGL: SPEC-3601
-
-Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
----
- data/command.xml                | 29 +++++++++++++++++++++++++++++
- src/waltham/header-preamble.txt |  1 +
- 2 files changed, 30 insertions(+)
-
-diff --git a/data/command.xml b/data/command.xml
-index a03082b..cb53f75 100644
---- a/data/command.xml
-+++ b/data/command.xml
-@@ -1814,6 +1814,35 @@
-   </interface>
-+  <interface name="wthp_ivi_app_id" version="1">
-+    <description summary="create ivi-style surfaces">
-+      This interface is exposed as a global singleton.
-+      This interface is implemented by servers that provide IVI-style user interfaces.
-+      It allows clients to associate an ivi_surface with wthp_surface.
-+    </description>
-+
-+    <enum name="error">
-+      <entry name="role" value="0" summary="given wthp_surface has another role"/>
-+    </enum>
-+
-+    <request name="surface_create">
-+      <description summary="create ivi_surface with app_id in ivi compositor">
-+        This request gives the wthp_surface the role of an IVI Surface. Creating more than
-+        one ivi_surface for a wthp_surface is not allowed. Note, that this still allows the
-+        following example:
-+
-+         1. create a wthp_surface
-+         2. create ivi_surface for the wthp_surface
-+         3. destroy the ivi_surface
-+
-+      </description>
-+      <arg name="app_id" type="string"/>
-+      <arg name="surface" type="object" interface="wthp_surface"/>
-+      <arg name="id" type="new_id" interface="wthp_ivi_surface"/>
-+    </request>
-+
-+  </interface>
-+
-   <interface name="dummy" version="1">
-     <request name="dummy_request">
-     </request>
-diff --git a/src/waltham/header-preamble.txt b/src/waltham/header-preamble.txt
-index df765cc..2409859 100644
---- a/src/waltham/header-preamble.txt
-+++ b/src/waltham/header-preamble.txt
-@@ -50,5 +50,6 @@ struct wthp_touch;
- struct wthp_ivi_surface;
- struct wthp_ivi_application;
-+struct wthp_ivi_app_id;
- struct dummy;
--- 
-2.28.0
-
diff --git a/meta-agl-core/recipes-graphics/wayland/waltham_%.bbappend b/meta-agl-core/recipes-graphics/wayland/waltham_%.bbappend
deleted file mode 100644 (file)
index 302eba4..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-
-SRC_URI:append = "\
-       file://0001-waltham-Fix-compile-build-error.patch \
-       file://0002-commandxml-Add-support-wthp_app_id-interface.patch \
-       file://0001-Use-python3-instead-of-2.patch \
-       "
diff --git a/meta-agl-core/recipes-graphics/wayland/waltham_git.bb b/meta-agl-core/recipes-graphics/wayland/waltham_git.bb
deleted file mode 100644 (file)
index da092a5..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-DESCRIPTION = "Waltham is a network IPC library designed to resemble Wayland both protocol and protocol-API wise"
-HOMEPAGE = "https://github.com/waltham/waltham"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = " \
-  file://LICENSE;md5=e8ad01a5182f2c1b3a2640e9ea268264 \
-"
-SRCREV = "1de58c3ff746ddaba7584d760c5454243723d3ca"
-SRC_URI = "git://github.com/wmizuno/waltham.git;branch=master;protocol=https \
-          "
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-DEPENDS += "libdrm virtual/kernel wayland"
-RDEPENDS:${PN} += "libdrm"
\ No newline at end of file
index 26233c5..746bde3 100644 (file)
@@ -3,7 +3,6 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 WESTON_DISPLAYS:append = "${@bb.utils.contains("DISTRO_FEATURES", "weston-remoting", " remote-output", "", d)}"
-WESTON_DISPLAYS:append = "${@bb.utils.contains("AGL_FEATURES", "waltham-remoting", " transmitter-output", "", d)}"
 
 # For virtual machines and intel-corei7-64 we want to support both the HDMI-A-1
 # and Virtual-1 outputs. This allows us to run virtual images on real hardware
diff --git a/meta-agl-core/recipes-graphics/wayland/weston/0001-libweston-Migrate-weston_seat_init-release-to-public.patch b/meta-agl-core/recipes-graphics/wayland/weston/0001-libweston-Migrate-weston_seat_init-release-to-public.patch
deleted file mode 100644 (file)
index 02af7cb..0000000
+++ /dev/null
@@ -1,106 +0,0 @@
-From 4534fcab54409b08faf4445ed6780136b58afb63 Mon Sep 17 00:00:00 2001
-From: Marius Vlad <marius.vlad@collabora.com>
-Date: Mon, 28 Sep 2020 22:51:00 +0300
-Subject: [PATCH 1/2] libweston: Migrate weston_seat_init/release to public
- headers
-
-weston_seat_init/release needed for creating weston plug-ins that want
-manage seat/input on their own.
-
-Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
----
- include/libweston/libweston.h  | 25 +++++++++++++++++++++++++
- libweston/libweston-internal.h | 31 +++----------------------------
- 2 files changed, 28 insertions(+), 28 deletions(-)
-
-diff --git a/include/libweston/libweston.h b/include/libweston/libweston.h
-index 54ea008..59541f2 100644
---- a/include/libweston/libweston.h
-+++ b/include/libweston/libweston.h
-@@ -2053,6 +2053,31 @@ void
- weston_timeline_refresh_subscription_objects(struct weston_compositor *wc,
-                                            void *object);
-+/* input, seat */
-+void
-+weston_seat_init(struct weston_seat *seat, struct weston_compositor *ec,
-+              const char *seat_name);
-+void
-+weston_seat_release(struct weston_seat *seat);
-+
-+void
-+weston_seat_init_pointer(struct weston_seat *seat);
-+
-+int
-+weston_seat_init_keyboard(struct weston_seat *seat, struct xkb_keymap *keymap);
-+
-+void
-+weston_seat_init_touch(struct weston_seat *seat);
-+
-+void
-+weston_seat_release_keyboard(struct weston_seat *seat);
-+
-+void
-+weston_seat_release_pointer(struct weston_seat *seat);
-+
-+void
-+weston_seat_release_touch(struct weston_seat *seat);
-+
- #ifdef  __cplusplus
- }
- #endif
-diff --git a/libweston/libweston-internal.h b/libweston/libweston-internal.h
-index 66c38e8..f5c4c2c 100644
---- a/libweston/libweston-internal.h
-+++ b/libweston/libweston-internal.h
-@@ -168,44 +168,19 @@ weston_plane_init(struct weston_plane *plane,
- void
- weston_plane_release(struct weston_plane *plane);
--/* weston_seat */
--
- struct clipboard *
- clipboard_create(struct weston_seat *seat);
--void
--weston_seat_init(struct weston_seat *seat, struct weston_compositor *ec,
--               const char *seat_name);
--
--void
--weston_seat_repick(struct weston_seat *seat);
-+/* weston_seat */
- void
--weston_seat_release(struct weston_seat *seat);
-+weston_seat_update_keymap(struct weston_seat *seat, struct xkb_keymap *keymap);
- void
- weston_seat_send_selection(struct weston_seat *seat, struct wl_client *client);
- void
--weston_seat_init_pointer(struct weston_seat *seat);
--
--int
--weston_seat_init_keyboard(struct weston_seat *seat, struct xkb_keymap *keymap);
--
--void
--weston_seat_init_touch(struct weston_seat *seat);
--
--void
--weston_seat_release_keyboard(struct weston_seat *seat);
--
--void
--weston_seat_release_pointer(struct weston_seat *seat);
--
--void
--weston_seat_release_touch(struct weston_seat *seat);
--
--void
--weston_seat_update_keymap(struct weston_seat *seat, struct xkb_keymap *keymap);
-+weston_seat_repick(struct weston_seat *seat);
- void
- wl_data_device_set_keyboard_focus(struct weston_seat *seat);
--- 
-2.28.0
-
index 546f5ec..b0025f5 100644 (file)
@@ -4,12 +4,8 @@ FILESEXTRAPATHS:append := ":${THISDIR}/weston"
 PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
 PACKAGECONFIG[headless] = "-Dbackend-headless=true"
 PACKAGECONFIG:append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
-PACKAGECONFIG:append = "${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', ' remoting', '', d)}"
 
 SRC_URI:append = "file://0001-libweston-Send-name-description-update-wl_output-to-.patch \
                  file://0001-libweston-desktop-xdg-shell-Add-tiled-orientation-st.patch \
                  file://0001-simple-touch-Add-maximized-fullscreen-states.patch \
                  file://0001-libweston-weston-log-Add-an-iterator-for-going-over-.patch"
-
-# seat management is only for waltham-transmitter-plugin
-SRC_URI:append = "${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', ' file://0001-libweston-Migrate-weston_seat_init-release-to-public.patch', '', d)}"
index 2b70860..13b5fdc 100644 (file)
@@ -16,7 +16,5 @@ RDEPENDS:${PN} += "\
     packagegroup-agl-graphical-weston \
     packagegroup-agl-graphical-multimedia \
 "
-# FIXME: Removed due to issues building against weston 5.0.0:
-#    waltham-transmitter
 
 RDEPENDS:profile-graphical = "${PN}"
diff --git a/templates/feature/agl-weston-waltham-remoting/50_local.conf.inc b/templates/feature/agl-weston-waltham-remoting/50_local.conf.inc
deleted file mode 100644 (file)
index d965eae..0000000
+++ /dev/null
@@ -1 +0,0 @@
-AGL_FEATURES:append = " waltham-remoting"
diff --git a/templates/feature/agl-weston-waltham-remoting/README_feature_agl-weston-waltham-remoting.md b/templates/feature/agl-weston-waltham-remoting/README_feature_agl-weston-waltham-remoting.md
deleted file mode 100644 (file)
index 416ff3f..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
----
-description: Feature agl-weston-waltham-remoting
-authors: Marius Vlad <marius.vlad@collabora.com>
----
-       
-### Feature agl-weston-waltham-remoting
-        
-Enables remote display configuration using libWeston's remoting plug-in
-for remote output and remote input using waltham-transmitter-plug-in.
diff --git a/templates/feature/agl-weston-waltham-remoting/included.dep b/templates/feature/agl-weston-waltham-remoting/included.dep
deleted file mode 100644 (file)
index 82639da..0000000
+++ /dev/null
@@ -1 +0,0 @@
-agl-demo