agl-selinux: pull in meta-clang 99/29899/2 master
authorScott Murray <scott.murray@konsulko.com>
Wed, 8 May 2024 18:59:37 +0000 (14:59 -0400)
committerScott Murray <scott.murray@konsulko.com>
Fri, 10 May 2024 15:59:47 +0000 (15:59 +0000)
Make pulling in meta-clang for the agl-selinx feature explicit, to
avoid dependency issues from the uutils-coreutils recipe in meta-oe.
This fixes building when configured with just the "agl-ic-container"
feature without "agl-demo".

Bug-AGL: SPEC-5123

Change-Id: Ie775b2e3ceb081448fc8b772f9686ad4dfbb45dc
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29899
ci-image-boot-test: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
Tested-by: Jenkins Job builder account
meta-agl-bsp/virtualization-layer/recipes-graphics/mesa/mesa/0001-virgl-virgl_driinfo.h.in-Disable-by-default-emulated.patch
meta-agl-bsp/virtualization-layer/recipes-graphics/mesa/mesa_24.%.bbappend [moved from meta-agl-bsp/virtualization-layer/recipes-graphics/mesa/mesa_22.%.bbappend with 100% similarity]
meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend [moved from meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_5.15.bbappend with 100% similarity]
templates/feature/agl-selinux/50_bblayers.conf.inc

index 8bc102c..d276960 100644 (file)
@@ -1,7 +1,8 @@
-From 39dea63ebce2764c683c8c2eddbb10cf07a970c4 Mon Sep 17 00:00:00 2001
+From 737ccb36c0faf275037e5e96a263c89a44886ddd Mon Sep 17 00:00:00 2001
 From: Marius Vlad <marius.vlad@collabora.com>
 Date: Mon, 19 Dec 2022 11:51:28 +0200
 Subject: [PATCH] virgl/virgl_driinfo.h.in: Disable by default emulated BGRA
+
  and swizzling
 
 Workaround in place for virtio aarch64 to avoid graphical artefacts when
@@ -16,10 +17,10 @@ Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
  1 file changed, 2 insertions(+), 2 deletions(-)
 
 diff --git a/src/gallium/drivers/virgl/virgl_driinfo.h.in b/src/gallium/drivers/virgl/virgl_driinfo.h.in
-index f57e5880965..1c06f932c5c 100644
+index ec688f5..244021e 100644
 --- a/src/gallium/drivers/virgl/virgl_driinfo.h.in
 +++ b/src/gallium/drivers/virgl/virgl_driinfo.h.in
-@@ -8,7 +8,7 @@
+@@ -8,8 +8,8 @@
  //   5. Implement the tweak in virglrenderer
  DRI_CONF_SECTION_MISCELLANEOUS
      DRI_CONF_FORMAT_L8_SRGB_ENABLE_READBACK(false)
@@ -28,7 +29,8 @@ index f57e5880965..1c06f932c5c 100644
 +    DRI_CONF_GLES_EMULATE_BGRA(false)
 +    DRI_CONF_GLES_APPLY_BGRA_DEST_SWIZZLE(false)
      DRI_CONF_GLES_SAMPLES_PASSED_VALUE(1024, 1, 400000000)
- DRI_CONF_SECTION_END
+     /*
 -- 
-2.35.1
+2.30.2
 
index b17e292..392b700 100644 (file)
@@ -1,5 +1,8 @@
 AGL_META_PYTHON = "${METADIR}/external/meta-openembedded/meta-python"
 
+# Needed to satisfy uutils-coreutils DEPENDS when using SELinux
+AGL_META_CLANG = "${METADIR}/external/meta-clang"
+
 BBLAYERS =+ " \
        ${METADIR}/external/meta-selinux \
        "