meta-rcar-gen3: gles: support for AGL toolchain 05/7205/2
authorYannick Gicquel <yannick.gicquel@iot.bzh>
Wed, 16 Nov 2016 14:31:01 +0000 (15:31 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 16 Nov 2016 19:12:35 +0000 (19:12 +0000)
As TARGET_VENDOR is defined in AGL, the toolchain has a
different name.
The gles recipe contains hardcoded toolchain name, this
add support to custom one.

Change-Id: Ie4e768d0570c6a07f92067e39079e6e063d59451
Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bbappend [new file with mode: 0644]

diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bbappend
new file mode 100644 (file)
index 0000000..8a4176f
--- /dev/null
@@ -0,0 +1,4 @@
+module_do_compile_prepend() {
+    cd ${S}/build/linux/config/compilers
+    cp aarch64-poky-linux.mk ${TARGET_SYS}.mk
+}