Support MinnowBoard MAX 79/5279/1
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Fri, 15 Jan 2016 13:12:18 +0000 (22:12 +0900)
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Fri, 15 Jan 2016 13:12:18 +0000 (22:12 +0900)
To configure for MinnowBoard MAX, use 'intel-corei7-64' as MACHINE.

E.g. set up build environment by meta-agl's script:
  $ source meta-agl/script/envsetup.sh intel-corei7-64 [build-dir]

There are instructions to write image into SD card and boot system
at "http://elinux.org/Minnowboard:MinnowMaxYoctoProject".

Change-Id: I19062482848bb6157791ab698bf92984e24a6d9a
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
meta-agl-bsp/recipes-graphics/mesa/mesa_10.%.bbappend
meta-agl-bsp/recipes-graphics/wayland/weston_%.bbappend
meta-agl-bsp/recipes-kernel/linux/linux-yocto/hid.cfg [new file with mode: 0644]
meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
meta-agl/conf/bblayers.conf.sample
meta-agl/recipes-core/systemd/systemd/e2fsck.conf [new file with mode: 0644]
meta-agl/recipes-core/systemd/systemd_%.bbappend
scripts/envsetup.sh

index fca193e..5280a26 100644 (file)
@@ -2,3 +2,5 @@
 RPROVIDES_${PN}_append = "libegl-gallium"
 
 PACKAGECONFIG_append = " gallium gallium-egl gallium-llvm"
+
+DRIDRIVERS_append_intel-corei7-64 = ",i965"
index a527fcf..53c58b5 100644 (file)
@@ -1,4 +1,6 @@
 RRECOMMENDS_${PN}_append = " libegl-gallium llvm3.3 "
+RRECOMMENDS_${PN}_remove_intel-corei7-64 = "libegl-gallium llvm3.3"
+RDEPENDS_${PN}_append_intel-corei7-64 = " mesa-megadriver "
 
 EXTRA_OECONF_append_vexpressa9 = "\
     --enable-simple-egl-clients  \
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto/hid.cfg b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/hid.cfg
new file mode 100644 (file)
index 0000000..327c753
--- /dev/null
@@ -0,0 +1 @@
+CONFIG_HID_MULTITOUCH=y
index 00270fa..6b8483e 100644 (file)
@@ -4,4 +4,5 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
 SRC_URI += "file://0001-fanotify-fix-notification-of-groups-with-inode-mount.patch \
             file://fanotify.cfg \
             file://uinput.cfg \
+            file://hid.cfg \
             "
index e5e5443..668f0fe 100644 (file)
@@ -14,6 +14,7 @@ BBLAYERS ?= " \
   ##OEROOT##/../meta-agl/meta-agl-bsp \
   ##OEROOT##/../meta-openembedded/meta-oe \
   ##OEROOT##/../meta-openembedded/meta-multimedia \
+  ##OEROOT##/../meta-intel \
   "
 BBLAYERS_NON_REMOVABLE ?= " \
   ##OEROOT##/meta \
diff --git a/meta-agl/recipes-core/systemd/systemd/e2fsck.conf b/meta-agl/recipes-core/systemd/systemd/e2fsck.conf
new file mode 100644 (file)
index 0000000..b774f9e
--- /dev/null
@@ -0,0 +1,3 @@
+[options]
+# This will prevent e2fsck from stopping boot just because the clock is wrong
+broken_system_clock = 1
index 29b7d1d..ef92695 100644 (file)
@@ -1,3 +1,13 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " file://e2fsck.conf "
+
 # enable networkd support
 PACKAGECONFIG_append_pn-systemd = " networkd"
 
+do_install_append() {
+    # Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
+    install -p -D ${WORKDIR}/e2fsck.conf ${D}/etc/e2fsck.conf
+}
+
+FILES_${PN} += " /etc/e2fsck.conf "
index d003301..adde540 100644 (file)
@@ -21,6 +21,10 @@ case "$1" in
                 # template conf for R-Car2 M2 Porter board
                 TEMPLATECONF=$PWD/meta-renesas/meta-rcar-gen2/conf
                 ;;
+        "intel-corei7-64")
+                # template conf for MinnowBoard MAX
+                TEMPLATECONF=$PWD/meta-agl-demo/conf
+                ;;
         "qemux86-64")
                 # template conf for QEMU x86-64
                 TEMPLATECONF=$PWD/meta-agl-demo/conf