native-shell-client: Add recipe 86/28186/2
authorScott Murray <scott.murray@konsulko.com>
Tue, 22 Nov 2022 08:27:32 +0000 (03:27 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 23 Nov 2022 14:04:04 +0000 (14:04 +0000)
Add recipe for native-shell-client simple agl-shell protocol client.
It can be used for testing agl-compositor and also enables using it
in simple usecases such as displaying the output from guest VMs with
QEMU+KVM.

Bug-AGL: SPEC-4618

Change-Id: I16b7c8b703b2aa3c875b7ffd78b24021eafd3a7f
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28186
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-core/recipes-graphics/wayland/native-shell-client_git.bb [new file with mode: 0644]

diff --git a/meta-agl-core/recipes-graphics/wayland/native-shell-client_git.bb b/meta-agl-core/recipes-graphics/wayland/native-shell-client_git.bb
new file mode 100644 (file)
index 0000000..b182715
--- /dev/null
@@ -0,0 +1,16 @@
+SUMMARY = "Minimal agl-shell Wayland protocol client"
+
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/q/project:src%252Fnative-shell-client"
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3b90ee643ce04400848a8f0deb492a4a"
+
+DEPENDS = "wayland wayland-protocols wayland-native agl-compositor"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/native-shell-client.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "03249cee92017337b1f2515b98a8f3b37459a256"
+
+PV = "0.0.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig