qtwayland_%.bbappend: Migrate the qt shell integration to the proper 01/24501/3
authorMarius Vlad <marius.vlad@collabora.com>
Tue, 12 May 2020 10:17:54 +0000 (13:17 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 13 May 2020 11:53:57 +0000 (11:53 +0000)
place

The proper place to choose the qtshell integration is with qtwayland so
migrate it there.

While at it, upgrade to xdg-shell stable instead of using the unstable v6.

Bug-AGL: SPEC-3133

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: I67b92cd744c4e34c9a603b9535823d9562d4bdf8

meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
meta-app-framework/recipes-core/af-main/af-main_git.bb

index 792a09f..408b2b6 100644 (file)
@@ -23,3 +23,12 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
 SRC_URI_append = "\
     file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
     "
+
+DEFAULT_WM_SHELL = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-compositor', 'xdg-shell', 'ivi-shell', d)}"
+AFM_CONF_DIR = "${D}${sysconfdir}/afm/unit.env.d"
+QT_SHELL_FILE = "${AFM_CONF_DIR}/qt-shell"
+
+do_install_append_class-target() {
+       mkdir -p ${AFM_CONF_DIR}
+       echo "QT_WAYLAND_SHELL_INTEGRATION=${DEFAULT_WM_SHELL}" > ${QT_SHELL_FILE}
+}
index e5a183a..917eaa4 100644 (file)
@@ -85,9 +85,6 @@ do_install_append_class-target() {
         ln -sf ../afm-system-daemon.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-system-daemon.service
         ln -sf ../afm-system-daemon.socket ${D}${systemd_system_unitdir}/sockets.target.wants/afm-system-daemon.socket
     fi
-
-    DEFAULT_WM_SHELL="${@bb.utils.contains('DISTRO_FEATURES', 'agl-compositor', 'xdg-shell-v6', 'ivi-shell', d)}"
-    echo "QT_WAYLAND_SHELL_INTEGRATION=${DEFAULT_WM_SHELL}" > ${D}${afm_confdir}/unit.env.d/qt-shell
 }
 
 pkg_postinst_ontarget_${PN}() {