meta-agl-profile-graphical-html5: remove layer and AGL feature 72/23072/3
authorJacobo Aragunde Pérez <jaragunde@igalia.com>
Wed, 27 Nov 2019 09:44:34 +0000 (10:44 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 6 Dec 2019 14:32:02 +0000 (14:32 +0000)
Remove old layer, based on OpenIVI and using deprecated QtWebKit, to
free up the name to be used by the Chromium-based web runtime.

Bug-AGL: SPEC-2322

Change-Id: I41730d629be846c2b0a624f5ab881ada31a8e0dc
Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com>
meta-agl-profile-graphical-html5/conf/layer.conf [deleted file]
meta-agl-profile-graphical-html5/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.service [deleted file]
meta-agl-profile-graphical-html5/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh [deleted file]
meta-agl-profile-graphical-html5/recipes-openivi/openivi-html5/openivi-html5_git.bb [deleted file]
meta-agl-profile-graphical-html5/recipes-platform/images/agl-demo-platform-html5-crosssdk.bb [deleted file]
meta-agl-profile-graphical-html5/recipes-platform/images/agl-demo-platform-html5.bb [deleted file]
meta-agl-profile-graphical-html5/recipes-platform/images/agl-demo-platform-html5.inc [deleted file]
meta-agl-profile-graphical-html5/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb [deleted file]
templates/feature/agl-profile-graphical-html5/50_bblayers.conf.inc [deleted file]
templates/feature/agl-profile-graphical-html5/README_feature_agl-profile-graphical-html5.md [deleted file]
templates/feature/agl-profile-graphical-html5/included.dep [deleted file]

diff --git a/meta-agl-profile-graphical-html5/conf/layer.conf b/meta-agl-profile-graphical-html5/conf/layer.conf
deleted file mode 100644 (file)
index 69967b0..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-# We have a conf and classes directory, add to BBPATH
-BBPATH =. "${LAYERDIR}:"
-
-# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
-            ${LAYERDIR}/recipes-*/*/*.bbappend"
-
-BBFILE_COLLECTIONS += "aglprofilegraphicalhtml5"
-BBFILE_PATTERN_aglprofilegraphicalhtml5 = "^${LAYERDIR}/"
-BBFILE_PRIORITY_aglprofilegraphicalhtml5 = "70"
-
-LAYERSERIES_COMPAT_aglprofilegraphicalhtml5 = "thud"
diff --git a/meta-agl-profile-graphical-html5/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.service b/meta-agl-profile-graphical-html5/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.service
deleted file mode 100644 (file)
index 2c86484..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-[Unit]
-Description=HTML5 runtime for OpenIVI Mobility applications
-Requires=afm-user-daemon.service InputEventManager.service
-After=afm-user-daemon.service InputEventManager.service
-ConditionKernelCommandLine=!agl.nogfx
-
-[Service]
-Type=dbus
-BusName=org.agl.openivi
-ExecStart=/usr/bin/openivi-html5.sh
-Restart=on-failure
-RestartSec=5
-TimeoutStopSec=1
-
-[Install]
-WantedBy=default.target
diff --git a/meta-agl-profile-graphical-html5/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh b/meta-agl-profile-graphical-html5/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh
deleted file mode 100644 (file)
index a318214..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/bin/sh
-
-if test -z "$XDG_CONFIG_DIRS"; then
-    export XDG_CONFIG_DIRS=/etc/xdg/
-fi
-
-if test -z "$XDG_RUNTIME_DIR"; then
-    export XDG_RUNTIME_DIR=/run/user/$UID
-    mkdir --parents $XDG_RUNTIME_DIR
-    chmod 0700 $XDG_RUNTIME_DIR
-fi
-
-# Default homescreen
-HOMESCREEN=/usr/share/openivi/example/cluster/index.html
-
-# Read configuration
-HOMESCREEN_CONFIG=$XDG_CONFIG_DIRS/openivi-html5/openivi-html5.ini
-if [ -e "$HOMESCREEN_CONFIG" ] ; then
-    HTML=`sed -n '/^homescreen=\(.*\)$/s//\1/p' <  $HOMESCREEN_CONFIG`
-    if [ -n "$HTML" ] ; then
-        HOMESCREEN=$HTML
-    fi
-fi
-
-#the following value shall be modified for your display side
-SCREEN_W=1080
-SCREEN_H=1920
-
-# Demo is configured to FullHD
-QT_W=1080
-QT_H=1920
-
-QT_IVI_SURFACE_ID=4194304 QT_WAYLAND_SHELL_INTEGRATION=ivi-shell /usr/bin/openivi-html5 -f -u $HOMESCREEN &
-
-# qmlscene create 2 surfaces
-#   0x80000000 : for off screen buffer ?
-#   0x80000001 : visible
-#
-SURFACE_ID_QML=0x80000001
-
-#
-# layer-add-surfaces wait till 2 surfaces are created.
-#
-layer-add-surfaces 1000 2
-
-/usr/bin/LayerManagerControl set surface $SURFACE_ID_QML destination region 0 0 $SCREEN_W $SCREEN_H
-/usr/bin/LayerManagerControl set surface $SURFACE_ID_QML source region 0 0 $QT_W $QT_H
-/usr/bin/LayerManagerControl set layer 1000 render order $SURFACE_ID_QML
-/usr/bin/LayerManagerControl set surfaces $SURFACE_ID_QML input focus keyboard
-/usr/bin/LayerManagerControl set screen 0 render order 1000
diff --git a/meta-agl-profile-graphical-html5/recipes-openivi/openivi-html5/openivi-html5_git.bb b/meta-agl-profile-graphical-html5/recipes-openivi/openivi-html5/openivi-html5_git.bb
deleted file mode 100644 (file)
index 168b98c..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-DESCRIPTION = "OpenIVI Mobility HTML5 environment"
-HOMEPAGE = "https://openivimobility.github.io/"
-SECTION = "base"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4641e94ec96f98fabc56ff9cc48be14b"
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI = " \
-       git://github.com/openivimobility/openivi-html5.git;branch=master;tag=0b370eea8c7c852365bd717013a523b678abbdba \
-       file://openivi-html5.sh \
-       file://openivi-html5.service \
-"
-
-inherit pkgconfig cmake_qt5 externalsrc systemd
-PV = "0.1"
-
-S = "${WORKDIR}/git"
-
-RDEPENDS_${PN} = "qtbase qtwebkit inputeventmanager windowmanager"
-DEPENDS = "qtbase-native qtbase qtwebkit"
-
-EXTRA_OECMAKE = " -DCMAKE_DISABLE_FIND_PACKAGE_X11=TRUE "
-
-FILES_${PN} = "/usr/bin/openivi-html5 /usr/share/openivi/*"
-
-do_install() {
-  install -d ${D}${bindir}
-  install -m 0755 openivi-html5 ${D}${bindir}
-
-  install -d ${D}${datadir}/openivi/
-  cp -r ${S}/example ${D}${datadir}/openivi/
-
-  install -p -D ${WORKDIR}/openivi-html5.sh ${D}${bindir}/openivi-html5.sh
-
-  if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-    install -d ${D}${systemd_user_unitdir}
-    install -p -D ${WORKDIR}/openivi-html5.service ${D}${systemd_user_unitdir}/openivi-html5.service
-    install -d ${D}${sysconfdir}/systemd/user/default.target.wants
-    ln -sf ${systemd_user_unitdir}/openivi-html5.service ${D}${sysconfdir}/systemd/user/default.target.wants
-  fi
-}
-
-FILES_${PN} += " ${prefix}/bin/openivi-html5.sh ${systemd_user_unitdir} ${sysconfdir}"
diff --git a/meta-agl-profile-graphical-html5/recipes-platform/images/agl-demo-platform-html5-crosssdk.bb b/meta-agl-profile-graphical-html5/recipes-platform/images/agl-demo-platform-html5-crosssdk.bb
deleted file mode 100755 (executable)
index 2d81120..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
-
-DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
-It includes the full meta-toolchain, plus developement headers and libraries \
-to form a standalone cross SDK."
-
-require agl-demo-platform-html5.bb
-
-LICENSE = "MIT"
-
-IMAGE_FEATURES_append = " dev-pkgs"
-IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
-
-inherit populate_sdk populate_sdk_qt5
-
-# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
-# Both exec "createrepo" on the same directory, and so one of them
-# can failed (randomly).
-addtask do_populate_sdk after do_rootfs
-
-# native tools to support Chromium build inside SDK (SPEC-942)
-TOOLCHAIN_HOST_TASK += " \
-    nativesdk-gn \
-    nativesdk-ninja \
-    nativesdk-gperf \
-    nativesdk-zlib \
-    nativesdk-xz \
-    nativesdk-nspr-dev \
-    nativesdk-nss-dev \
-    nativesdk-lua \
-    "
-
-# required dependencies for Chromium build inside SDK (SPEC-942)
-TOOLCHAIN_TARGET_TASK += " \
-    pciutils-dev \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-dev' , '', d)} \
-    cairo-dev \
-    nss-dev \
-    cups-dev \
-    gconf-dev \
-    libexif-dev \
-    pango-dev \
-    libdrm-dev  \
-    lua-dev \
-    lua-staticdev \
-    ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'ffmpeg-dev', '', d)} \
-    "
-
-# Add wayland-scanner to SDK (SPEC-945)
-# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
-# wayland-scanner is in nativesdk-wayland-dev !
-# option: add also nativesdk-qtwayland-tools
-TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
-
-TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "
diff --git a/meta-agl-profile-graphical-html5/recipes-platform/images/agl-demo-platform-html5.bb b/meta-agl-profile-graphical-html5/recipes-platform/images/agl-demo-platform-html5.bb
deleted file mode 100644 (file)
index c9247a8..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
-demos."
-
-LICENSE = "MIT"
-
-require agl-demo-platform-html5.inc
-
-IMAGE_INSTALL_append = "\
-    packagegroup-agl-demo-platform-html5 \
-    "
diff --git a/meta-agl-profile-graphical-html5/recipes-platform/images/agl-demo-platform-html5.inc b/meta-agl-profile-graphical-html5/recipes-platform/images/agl-demo-platform-html5.inc
deleted file mode 100644 (file)
index f2f2886..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-# Base image
-require recipes-platform/images/agl-image-minimal.inc
diff --git a/meta-agl-profile-graphical-html5/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/meta-agl-profile-graphical-html5/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
deleted file mode 100644 (file)
index ee5c1f7..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-SUMMARY = "The software for DEMO platform of AGL IVI profile"
-DESCRIPTION = "A set of packages belong to AGL Demo Platform"
-
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PACKAGES = "\
-    packagegroup-agl-demo-platform-html5 \
-    "
-
-ALLOW_EMPTY_${PN} = "1"
-
-RDEPENDS_${PN} += "\
-    packagegroup-agl-image-ivi \
-    "
-
-# add packages for demo platform (include demo apps) here
-#RDEPENDS_${PN} += " \
-#    packagegroup-agl-demo \
-#    "
-
-# add packages for OpenIVI-HTML5 demo
-RDEPENDS_${PN} += " \
-    openivi-html5 \
-    "
diff --git a/templates/feature/agl-profile-graphical-html5/50_bblayers.conf.inc b/templates/feature/agl-profile-graphical-html5/50_bblayers.conf.inc
deleted file mode 100644 (file)
index 97b44a2..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-BBLAYERS =+ " \
-  ${METADIR}/meta-agl/meta-agl-profile-graphical-html5 \
-"
diff --git a/templates/feature/agl-profile-graphical-html5/README_feature_agl-profile-graphical-html5.md b/templates/feature/agl-profile-graphical-html5/README_feature_agl-profile-graphical-html5.md
deleted file mode 100644 (file)
index 48bf84b..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
----
-description: Feature agl-profile-graphical-html5
-authors: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
----
-       
-### Feature agl-profile-graphical-html5
-        
-*Description is missing - please complete file meta-agl/templates/feature/agl-profile-graphical-html5/README_feature_agl-profile-graphical-html5.md*
-
-#### Dependent features pulled by agl-profile-graphical-html5
-
-The following features are pulled:
-
-* agl-profile-graphical
-
diff --git a/templates/feature/agl-profile-graphical-html5/included.dep b/templates/feature/agl-profile-graphical-html5/included.dep
deleted file mode 100644 (file)
index 5b54430..0000000
+++ /dev/null
@@ -1 +0,0 @@
-agl-profile-graphical 
\ No newline at end of file