Add media automounting support 39/8939/4
authorMatt Ranostay <matt.ranostay@konsulko.com>
Mon, 27 Mar 2017 18:24:12 +0000 (21:24 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 4 Apr 2017 08:46:11 +0000 (08:46 +0000)
Use the automount.rules from udev-extraconf for mounting and
unmounting removable media

AGL-Issue: SPEC-483
Change-Id: I8c0353a76d5080ec2e4eff9dc4a48ba771e7a393
Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
meta-agl/recipes-core/systemd/systemd/automount-rules [new file with mode: 0644]
meta-agl/recipes-core/systemd/systemd/mount.sh [new file with mode: 0644]
meta-agl/recipes-core/systemd/systemd_%.bbappend

diff --git a/meta-agl/recipes-core/systemd/systemd/automount-rules b/meta-agl/recipes-core/systemd/systemd/automount-rules
new file mode 100644 (file)
index 0000000..62578ea
--- /dev/null
@@ -0,0 +1,19 @@
+# There are a number of modifiers that are allowed to be used in some
+# of the different fields. They provide the following subsitutions:
+#
+# %n the "kernel number" of the device.
+#    For example, 'sda3' has a "kernel number" of '3'
+# %e the smallest number for that name which does not matches an existing node
+# %k the kernel name for the device
+# %M the kernel major number for the device
+# %m the kernel minor number for the device
+# %b the bus id for the device
+# %c the string returned by the PROGRAM
+# %s{filename} the content of a sysfs attribute
+# %% the '%' char itself
+#
+
+# Media automounting
+SUBSYSTEM=="block", ACTION=="add"    RUN+="/etc/udev/scripts/mount.sh"
+SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh"
+SUBSYSTEM=="block", ACTION=="change", ENV{DISK_MEDIA_CHANGE}=="1" RUN+="/etc/udev/scripts/mount.sh"
diff --git a/meta-agl/recipes-core/systemd/systemd/mount.sh b/meta-agl/recipes-core/systemd/systemd/mount.sh
new file mode 100644 (file)
index 0000000..cd72b05
--- /dev/null
@@ -0,0 +1,90 @@
+#!/bin/sh
+#
+# Called from udev
+#
+# Attempt to mount any added block devices and umount any removed devices
+
+
+MOUNT="/bin/mount -o ro"
+PMOUNT="/usr/bin/pmount"
+UMOUNT="/bin/umount -f"
+for line in `grep -h -v ^# /etc/udev/mount.blacklist /etc/udev/mount.blacklist.d/*`
+do
+       if [ ` expr match "$DEVNAME" "$line" ` -gt 0 ];
+       then
+               logger "udev/mount.sh" "[$DEVNAME] is blacklisted, ignoring"
+               exit 0
+       fi
+done
+
+automount() {  
+       name="`basename "$DEVNAME"`"
+
+       ! test -d "/run/media/$name" && mkdir -p "/run/media/$name"
+       # Silent util-linux's version of mounting auto
+       if [ "x`readlink $MOUNT`" = "x/bin/mount.util-linux" ] ;
+       then
+               MOUNT="$MOUNT -o silent"
+       fi
+       
+       # If filesystem type is vfat, change the ownership group to 'disk', and
+       # grant it with  w/r/x permissions.
+       case $ID_FS_TYPE in
+       vfat|fat)
+               MOUNT="$MOUNT -o umask=007,gid=`awk -F':' '/^disk/{print $3}' /etc/group`"
+               ;;
+       # TODO
+       *)
+               ;;
+       esac
+
+       if ! $MOUNT -t auto $DEVNAME "/run/media/$name"
+       then
+               #logger "mount.sh/automount" "$MOUNT -t auto $DEVNAME \"/run/media/$name\" failed!"
+               rm_dir "/run/media/$name"
+       else
+               logger "mount.sh/automount" "Auto-mount of [/run/media/$name] successful"
+               touch "/tmp/.automount-$name"
+       fi
+}
+       
+rm_dir() {
+       # We do not want to rm -r populated directories
+       if test "`find "$1" | wc -l | tr -d " "`" -lt 2 -a -d "$1"
+       then
+               ! test -z "$1" && rm -r "$1"
+       else
+               logger "mount.sh/automount" "Not removing non-empty directory [$1]"
+       fi
+}
+
+# No ID_FS_TYPE for cdrom device, yet it should be mounted
+name="`basename "$DEVNAME"`"
+[ -e /sys/block/$name/device/media ] && media_type=`cat /sys/block/$name/device/media`
+
+if [ "$ACTION" = "add" ] && [ -n "$DEVNAME" ] && [ -n "$ID_FS_TYPE" -o "$media_type" = "cdrom" ]; then
+       if [ -x "$PMOUNT" ]; then
+               $PMOUNT $DEVNAME 2> /dev/null
+       elif [ -x $MOUNT ]; then
+               $MOUNT $DEVNAME 2> /dev/null
+       fi
+       
+       # If the device isn't mounted at this point, it isn't
+       # configured in fstab (note the root filesystem can show up as
+       # /dev/root in /proc/mounts, so check the device number too)
+       if expr $MAJOR "*" 256 + $MINOR != `stat -c %d /`; then
+               grep -q "^$DEVNAME " /proc/mounts || automount
+       fi
+fi
+
+
+if [ "$ACTION" = "remove" ] || [ "$ACTION" = "change" ] && [ -x "$UMOUNT" ] && [ -n "$DEVNAME" ]; then
+       for mnt in `cat /proc/mounts | grep "$DEVNAME" | cut -f 2 -d " " `
+       do
+               $UMOUNT $mnt
+       done
+       
+       # Remove empty directories from auto-mounter
+       name="`basename "$DEVNAME"`"
+       test -e "/tmp/.automount-$name" && rm_dir "/run/media/$name"
+fi
index ef877c0..a3213dc 100644 (file)
@@ -1,6 +1,8 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
 SRC_URI += "file://e2fsck.conf \
+            file://automount-rules \
+            file://mount.sh \
             ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','file://wired.network','',d)} \
            "
 
@@ -13,6 +15,11 @@ do_install_append() {
     # Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
     install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
 
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'automount', 'true', 'false', d)}; then
+        install -m 644 -p -D ${WORKDIR}/automount-rules ${D}${sysconfdir}/udev/rules.d/automount.rules
+        install -m 755 -p -D ${WORKDIR}/mount.sh ${D}${sysconfdir}/udev/scripts/mount.sh
+    fi
+
     if ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','true','false',d)}; then
        # Install DHCP configuration for Ethernet adapters
        install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network