libsdl2: PACKAGECONFIG tweaks 55/28255/2
authorScott Murray <scott.murray@konsulko.com>
Wed, 23 Nov 2022 21:33:29 +0000 (16:33 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 14 Dec 2022 16:28:38 +0000 (16:28 +0000)
Add a couple of bbappends for libsdl2 to tweak its PACKAGECONFIG,
based on Panasonic QEMU+KVM documentation.

Bug-AGL: SPEC-4618

Change-Id: I7ceb4e46faa88f09311ad359a3b0b13a462f6cb2
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28192
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
(cherry picked from commit 4255457f54a107e9399dd4834444191b855f7d44)
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28255
ci-image-boot-test: Jenkins Job builder account

meta-agl-core/recipes-graphics/libsdl2/libsdl2_%.bbappend [new file with mode: 0644]
meta-agl-core/recipes-graphics/libsdl2/libsdl2_aglcore.inc [new file with mode: 0644]

diff --git a/meta-agl-core/recipes-graphics/libsdl2/libsdl2_%.bbappend b/meta-agl-core/recipes-graphics/libsdl2/libsdl2_%.bbappend
new file mode 100644 (file)
index 0000000..48e5078
--- /dev/null
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'aglcore', 'libsdl2_aglcore.inc', '', d)}
diff --git a/meta-agl-core/recipes-graphics/libsdl2/libsdl2_aglcore.inc b/meta-agl-core/recipes-graphics/libsdl2/libsdl2_aglcore.inc
new file mode 100644 (file)
index 0000000..7652e18
--- /dev/null
@@ -0,0 +1,3 @@
+# Make sure opengl is disabled, as using wayland implies gles2 in the
+# libsdl2 PACKAGECONFIG definitions.
+PACKAGECONFIG:remove = "opengl"