af-platform-setup: Add recipe for setting platform 53/21653/10
authorJosé Bollo <jose.bollo@iot.bzh>
Tue, 11 Jun 2019 20:58:40 +0000 (22:58 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 19 Jun 2019 13:05:28 +0000 (13:05 +0000)
The Application Framework has implications
on platform setup. This commit introduces a
recipe that at the end would group all these
required setup at on place.

Bug-AGL: SPEC-1015

Change-Id: I45904ba269883329295bcbc3c70427edbfdd674f
Signed-off-by: José Bollo <jose.bollo@iot.bzh>
meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb [new file with mode: 0644]
meta-app-framework/recipes-core/af-platform-setup/files/udev-shared.conf [new file with mode: 0644]
meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb

diff --git a/meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb b/meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb
new file mode 100644 (file)
index 0000000..0963875
--- /dev/null
@@ -0,0 +1,16 @@
+HOMEPAGE = "here"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "file://udev-shared.conf"
+
+S = "${WORKDIR}"
+
+do_install() {
+       d=${D}${systemd_system_unitdir}/systemd-udevd.service.d
+       install -d $d
+       install ${S}/udev-shared.conf $d
+}
+
+FILES_${PN} = "${systemd_system_unitdir}"
diff --git a/meta-app-framework/recipes-core/af-platform-setup/files/udev-shared.conf b/meta-app-framework/recipes-core/af-platform-setup/files/udev-shared.conf
new file mode 100644 (file)
index 0000000..cce02bc
--- /dev/null
@@ -0,0 +1,4 @@
+[Service]
+ExecStartPre=/bin/mkdir -p /run/udev
+ExecStartPre=/usr/bin/chsmack -r -a System::Shared -t /run/udev
+
index 3944c19..854835d 100644 (file)
@@ -16,4 +16,5 @@ RDEPENDS_${PN} += "\
        af-main \
        nss-localuser \
        systemd-agl-sync \
+       af-platform-setup \
        "