agl-shell-activator_git: Add recipe 48/26348/3 11.91.0 lamprey/11.91.0 lamprey_11.91.0
authorMarius Vlad <marius.vlad@collabora.com>
Wed, 12 May 2021 09:59:13 +0000 (12:59 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 13 May 2021 21:54:39 +0000 (21:54 +0000)
This adds the recipe for agl-activator/agl-shell-activator, a simple
tool that switches (already started) applications. It assumes the first
output, but can be enhanced to support use multi output if needed.

Bug-AGL: SPEC-3817

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: I32f8bb246d75591cd7fc4f7d4b4047ee2b8f1b09
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26348
ci-image-build: Jenkins Job builder account
Tested-by: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb [new file with mode: 0644]

diff --git a/meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb b/meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb
new file mode 100644 (file)
index 0000000..fe0b61f
--- /dev/null
@@ -0,0 +1,22 @@
+SUMMARY = " Application that switches/activates other application's windows "
+DESCRIPTION = " A wayland client and a script that talks with the agl-compositor \
+an tells it to display a specific application. Relies on the appid being \
+started (already) by afm-util or the client shell (homescreen/WAM)"
+
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/q/project:src%252Fagl-shell-activator"
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e978448a0d41d826d73890d9c22caf75"
+
+DEPENDS = "wayland wayland-protocols wayland-native agl-compositor"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-shell-activator.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "5bdedb16112fa0faaf16f64ef440f451e9f787e4"
+
+PV = "0.0.10+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig python3native
+
+FILES_${PN} = " ${bindir}/agl-shell-activator \
+                ${bindir}/agl-activator "