linux: config: move BBE-specific fragment from meta-agl-core to meta-agl-bsp 03/28203/2
authorDenys Dmytriyenko <denys@konsulko.com>
Mon, 28 Nov 2022 20:44:17 +0000 (20:44 +0000)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 8 Dec 2022 05:32:26 +0000 (05:32 +0000)
Commit d009fa0c42042a0b7d069779852953621e46469b as part of SPEC-4156 added a
kernel config fragment to disable CONFIG_RELAY. Since this fragment is only
applied to BBE, there's no need for it to reside in meta-agl-core and can be
moved to meta-agl-bsp/meta-sancloud.

Bug-AGL: SPEC-4156
Change-Id: I5da2632d6eb00bbf99ddb48cef861564d2ce868d
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28203
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe/disable-relay.cfg [moved from meta-agl-core/recipes-kernel/linux/linux/disable-relay.cfg with 100% similarity]
meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe_%.bbappend
meta-agl-core/recipes-kernel/linux/linux-agl-config.inc

index b3709a2..803d4a9 100644 (file)
@@ -3,3 +3,4 @@ require recipes-kernel/linux/linux-agl.inc
 FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
 
 AGL_KCONFIG_FRAGMENTS += "cma-256.cfg"
+AGL_KCONFIG_FRAGMENTS += "disable-relay.cfg"
index 67fe022..bdca5d4 100644 (file)
@@ -49,7 +49,6 @@ AGL_KCONFIG_FRAGMENTS += "sound.cfg"
 
 # Enable support for SystemTap
 AGL_KCONFIG_FRAGMENTS += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'systemtap.cfg', '', d)}"
-AGL_KCONFIG_FRAGMENTS:bbe += "disable-relay.cfg"
 
 #
 # Feature override and qemu specific appends: