Remove the amqp package from azure-iot-sdk build 05/25005/2
authorLeonid Lazarev <leonid.lazarev@orioninc.com>
Mon, 13 Jul 2020 13:47:57 +0000 (16:47 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 15 Jul 2020 17:10:32 +0000 (17:10 +0000)
At the moment the yocto receipt for azure-iot-sdk does not include
amqp symbols in libiothub_client.so library. It has been done due to build issue.

In result the amqp related symbols in libiothub_client.so are not resolved.
As the amqp is not used by AGL (cloudproxy service) at the moment, it is disabled at all.

Bug-AGL: SPEC-3496

Change-Id: I803a30c480f59e4f07f7dcb098b3d96bb6dcb6f1
Signed-off-by: Leonid Lazarev <leonid.lazarev@orioninc.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25005
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-iot-cloud/recipes-azure/azure-iot-sdk-c/azure-iot-sdk-c_%.bbappend [new file with mode: 0644]

diff --git a/meta-agl-bsp/meta-iot-cloud/recipes-azure/azure-iot-sdk-c/azure-iot-sdk-c_%.bbappend b/meta-agl-bsp/meta-iot-cloud/recipes-azure/azure-iot-sdk-c/azure-iot-sdk-c_%.bbappend
new file mode 100644 (file)
index 0000000..ecd5fe2
--- /dev/null
@@ -0,0 +1,5 @@
+# Disable the amqp transport, due to linking error in meta-iot repository for amqp
+# symbols from amqp code are not included in the libiothub_client.so
+
+# NOTE: amqp is not used by AGL in IoT context at the moment
+PACKAGECONFIG_remove = "amqp"