Add Yocto Project mickledore release compatibility
authorDenys Dmytriyenko <denys@konsulko.com>
Fri, 6 Jan 2023 18:27:33 +0000 (18:27 +0000)
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>
Thu, 7 Mar 2024 12:55:01 +0000 (12:55 +0000)
Switch to mickledore in LAYERSERIES_COMPAT in layer.conf files.

Bug-AGL: SPEC-4578
Change-Id: I6363128896c27a713f7dd59c8a889306a2a04912
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28366
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/conf/layer.conf
meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
meta-agl-core/conf/layer.conf
meta-app-framework/conf/layer.conf
meta-netboot/conf/layer.conf
meta-pipewire/conf/layer.conf

index ba6d0bb..b9b5d50 100644 (file)
@@ -23,4 +23,4 @@ BBFILE_COLLECTIONS += "aglbsp"
 BBFILE_PATTERN_aglbsp = "^${LAYERDIR}/"
 BBFILE_PRIORITY_aglbsp = "60"
 
-LAYERSERIES_COMPAT_aglbsp = "kirkstone langdale"
+LAYERSERIES_COMPAT_aglbsp = "kirkstone langdale mickledore"
index 1e6c04c..95dcaa5 100644 (file)
@@ -15,4 +15,4 @@ BBFILE_COLLECTIONS += "rcar-gen3-cogent"
 BBFILE_PATTERN_rcar-gen3-cogent := "^${LAYERDIR}/"
 BBFILE_PRIORITY_rcar-gen3-cogent = "7"
 
-LAYERSERIES_COMPAT_rcar-gen3-cogent = "kirkstone langdale"
+LAYERSERIES_COMPAT_rcar-gen3-cogent = "kirkstone langdale mickledore"
index d9ee57d..6921e41 100644 (file)
@@ -20,7 +20,7 @@ BBFILES_DYNAMIC += " \
     qt5-layer:${LAYERDIR}/dynamic-layers/meta-qt5/*/*/*.bbappend \
 "
 
-LAYERSERIES_COMPAT_aglcore = "kirkstone langdale"
+LAYERSERIES_COMPAT_aglcore = "kirkstone langdale mickledore"
 LAYERDEPENDS_aglcore = "core"
 
 # Sanity check for meta-virtualization layer.
index 0d3a215..5417076 100644 (file)
@@ -9,5 +9,5 @@ BBFILE_COLLECTIONS += "meta-app-framework"
 BBFILE_PATTERN_meta-app-framework = "^${LAYERDIR}/"
 BBFILE_PRIORITY_meta-app-framework = "60"
 
-LAYERSERIES_COMPAT_meta-app-framework = "kirkstone langdale"
+LAYERSERIES_COMPAT_meta-app-framework = "kirkstone langdale mickledore"
 LAYERDEPENDS_meta-app-framework = "core aglcore openembedded-layer"
index 5413233..f890b7d 100644 (file)
@@ -9,5 +9,5 @@ BBFILE_COLLECTIONS += "meta-netboot"
 BBFILE_PATTERN_meta-netboot = "^${LAYERDIR}/"
 BBFILE_PRIORITY_meta-netboot = "60"
 
-LAYERSERIES_COMPAT_meta-netboot = "kirkstone langdale"
+LAYERSERIES_COMPAT_meta-netboot = "kirkstone langdale mickledore"
 LAYERDEPENDS_meta-netboot = "core networking-layer"
index 7a19d8e..bbbaf02 100644 (file)
@@ -9,7 +9,7 @@ BBFILE_COLLECTIONS += "meta-pipewire"
 BBFILE_PATTERN_meta-pipewire = "^${LAYERDIR}/"
 BBFILE_PRIORITY_meta-pipewire = "71"
 
-LAYERSERIES_COMPAT_meta-pipewire = "kirkstone langdale"
+LAYERSERIES_COMPAT_meta-pipewire = "kirkstone langdale mickledore"
 LAYERDEPENDS_meta-pipewire = "openembedded-layer"
 
 #