agl-compositor_git: Bump SRCREV 09/25309/6
authorMarius Vlad <marius.vlad@collabora.com>
Mon, 21 Sep 2020 12:52:49 +0000 (15:52 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 13 Oct 2020 10:30:26 +0000 (10:30 +0000)
This bump brings brings a bug-fix for a corner-case that dealt with
hiding/showing surfaces, and it adds the agl-screenshooter protocol and
a client with it -- useful to allowing users to take a screenshot but
also in CI to have some basic sanity testing.

In detail, the following changes have been added:

9bb8ea6f615650 Use a configuration option for hidding out the cursor
17d86f9b8afa69 main: Enable screenshoter interface when debug option is passed
3ba840cd3a5a2f input: Add basic seat handling
be8288cc5b1270 client/screenshooter: Client for taking screenshots
991714fc7f92ae screenshooter: Add agl-screenshooter protocol
1f888f2050ac50 layout: Set active output NULL when displaying background

Squashed and install agl-screenshooter client in the same commit to
please yocto/OE.

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: I19d2b3e3176bae3586cb2913aeacbd25fd48bde7
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25309
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb

index 1e3162f..b7a672c 100644 (file)
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
 DEPENDS = "wayland wayland-protocols wayland-native weston"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "0056122343c782902457802bb1ef6bde7c14d3c9"
+SRCREV = "9bb8ea6f6156502bf1639ce349907b391e9b124d"
 
 PV = "0.0.10+git${SRCPV}"
 S = "${WORKDIR}/git"
@@ -22,6 +22,7 @@ inherit meson pkgconfig python3native
 
 FILES_${PN} = " \
                ${bindir}/agl-compositor \
+               ${bindir}/agl-screenshooter \
                ${datadir}/${PN}/protocols/agl-shell.xml \
                ${datadir}/${PN}/protocols/agl-shell-desktop.xml \
               "