Merge "Provide Bluetooth and BlueZ 5"
authorWalt Miner <wminer@linuxfoundation.org>
Fri, 23 Oct 2015 15:03:34 +0000 (15:03 +0000)
committerGerrit Code Review <gerrit@172.30.200.200>
Fri, 23 Oct 2015 15:03:34 +0000 (15:03 +0000)
meta-agl/conf/distro/poky-agl.conf
meta-agl/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend [new file with mode: 0644]

index 0f5a191..58abfcd 100644 (file)
@@ -19,7 +19,7 @@ VIRTUAL-RUNTIME_init_manager = "systemd"
 VIRTUAL-RUNTIME_initscripts = ""
 
 # Override these in poky based distros
-AGL_DEFAULT_DISTRO_FEATURES = "systemd opengl wayland pam"
+AGL_DEFAULT_DISTRO_FEATURES = "systemd opengl wayland pam bluetooth bluez5"
 AGL_DEFAULT_EXTRA_RDEPENDS = "packagegroup-core-boot"
 AGL_DEFAULT_EXTRA_RRECOMMENDS = "kernel-module-af-packet"
 
diff --git a/meta-agl/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend b/meta-agl/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
new file mode 100644 (file)
index 0000000..2d9f558
--- /dev/null
@@ -0,0 +1,6 @@
+# Prevent BlueZ 4 from being always pulled
+PACKAGECONFIG_remove = "bluez4"
+
+# If Bluetooth is asked in DISTRO_FEATURES, verify if Bluez 5 is also
+# explicitly specified. If it is not, fall back to BlueZ 4
+PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5', 'bluez4', d), '', d)}"