packagegroup-agl-test: Install nmap. 36/25636/5
authorVasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>
Mon, 23 Nov 2020 19:34:43 +0000 (21:34 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 11 Dec 2020 21:43:26 +0000 (21:43 +0000)
nmap package provides ncat which was written for the Nmap Project as a
much-improved reimplementation of the venerable Netcat for the 21st
century [1].

It can be used to verify vsock communication [2].

Connect from driver VM to device VM:

On device VM run: `ncat --vsock -l 1234`
On driver VM run: `ncat --vsock 2 1234`, here 2 is VMADDR_CID_HOST, see
[3].

Connect from device VM to driver VM:

On driver VM run: `ncat --vsock -l 1234`
On device VM run: `ncat --vsock CID 1234`, here CID should be replaced
with driver VM CID.

[1]: https://nmap.org/ncat/
[2]: `main socat` section "AF_VSOCK SOCKETS"
[3]: `man vsock`

Bug-AGL: SPEC-3700
Change-Id: I92043eca33111f1921f739f355f35fda01467efb
Signed-off-by: Vasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25636
Reviewed-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Reviewed-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-profile-core/recipes-test/packagegroups/packagegroup-agl-test.bb

index b4502a1..412d438 100644 (file)
@@ -27,6 +27,7 @@ RDEPENDS_${PN} += "\
     linus-stress \
     lmbench \
     nbench-byte \
+    nmap \
     rt-tests \
     stress \
     "