agl-compositor: include runtime dependencies in PACKAGECONFIG for policy-rba 03/25903/2
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 13 Jan 2021 15:03:47 +0000 (16:03 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 13 Jan 2021 17:43:18 +0000 (17:43 +0000)
Update the PACKAGECONFIG line to include run time dependencies next to the compile time dependencies.
Without these there is not policy file in the image leading to:

[14:54:42.539] Sending ready to systemd
[14:54:43.126] Unable to find /etc/rba/RBAModel.json file!!
[14:54:43.126] libwayland: error in client communication (pid 851)
[14:54:43.244] Unable to find /etc/rba/RBAModel.json file!!
[14:54:43.244] libwayland: error in client communication (pid 837)

Bug-AGL: SPEC-3738

Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: I95052f51c24957c89aaa8da4385b7bf878eebf03
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25903
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>

meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb

index 414ff06..ccf7b88 100644 (file)
@@ -17,7 +17,7 @@ PV = "0.0.10+git${SRCPV}"
 S = "${WORKDIR}/git"
 
 PACKAGECONFIG ?= ""
-PACKAGECONFIG[policy-rba] = "-Dpolicy-default=rba,,librba rba-config"
+PACKAGECONFIG[policy-rba] = "-Dpolicy-default=rba,,librba,librba rba-config"
 PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
 
 inherit meson pkgconfig python3native