meta-agl-bsp/meta-renesas: weston.ini for Reneses 47/7147/3
authorLeon Anavi <leon.anavi@konsulko.com>
Thu, 10 Nov 2016 14:49:21 +0000 (16:49 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 11 Nov 2016 13:41:45 +0000 (13:41 +0000)
Add weston.ini with preconfigured but commented
out screen resolutions in the output section.
Weston 1.9 with DRM backend on Renesas Porter
board is known to be picky about monitors and
screen resolutions. This way the developer can
quickly switch to another configuration if the
default fails on the current monitor. This patch
should be considered as a temporary work around
until there is a generic solution.

Bug-AGL: SPEC-298

Change-Id: I772945a083ef4cab240c49e03c5f0cf1172a6ab2
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini [new file with mode: 0644]
meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend [new file with mode: 0644]

diff --git a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini
new file mode 100644 (file)
index 0000000..de3e7e8
--- /dev/null
@@ -0,0 +1,15 @@
+[core]
+shell=desktop-shell.so
+backend=drm-backend.so
+
+[shell]
+locking=true
+# Uncomment below to hide panel
+#panel-location=none
+
+[output]
+name=HDMI-A-1
+#mode=173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
+#mode=1920x1080
+#mode=1024x768
+#transform=90
diff --git a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644 (file)
index 0000000..842c380
--- /dev/null
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+    file://weston-renesas.ini \
+    "
+
+do_install_append() {
+    WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+    install -d ${D}${WESTON_INI_CONFIG}
+    install -m 0644 ${WORKDIR}/weston-renesas.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+}
+
+FILES_${PN} += " \
+    ${sysconfdir}/xdg/weston/weston.ini \
+    "