Add backported patch to overcome host contamination issue 58/26558/2
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 12 Aug 2021 13:30:38 +0000 (15:30 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 17 Aug 2021 12:23:25 +0000 (12:23 +0000)
This patch is required to fix a cross-compilation issue due to host contamination.
It is a backport from meta-openembedded master branch and submitted to dunfell.

Bug-AGL: SPEC-4051
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: I22aa1777d1e8606c54c873f53e380263f8f8a05b
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26558
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-agl-bsp/openembedded-layer/recipes-support/xmlsec1/files/ensure-search-path-non-host.patch [new file with mode: 0644]
meta-agl-bsp/openembedded-layer/recipes-support/xmlsec1/xmlsec1_1.2.%.bbappend [new file with mode: 0644]

diff --git a/meta-agl-bsp/openembedded-layer/recipes-support/xmlsec1/files/ensure-search-path-non-host.patch b/meta-agl-bsp/openembedded-layer/recipes-support/xmlsec1/files/ensure-search-path-non-host.patch
new file mode 100644 (file)
index 0000000..a5a298a
--- /dev/null
@@ -0,0 +1,22 @@
+xmlsec1: Fix configure QA error caused by host lookup path
+
+ERROR: mc:my-sdk:xmlsec1-1.2.30-r0 do_configure: QA Issue: This autoconf log indicates errors, it looked at host include and/or library paths while determining system capabilities.
+
+It will eventually arise after the configure QA as the configure script should only look at the staging sysroot dir, not at the host.
+
+Upstream-Status: Inappropriate [embedded specific]
+Signed-off-by: Anatol Belski <anbelski@linux.microsoft.com>
+
+--- a/configure.ac.orig   2021-01-13 14:37:42.254991177 +0000
++++ b/configure.ac        2021-01-13 14:40:56.546269330 +0000
+@@ -250,8 +250,8 @@
+ dnl ==========================================================================
+ dnl Common installation locations
+ dnl ==========================================================================
+-COMMON_INCLUDE_DIR="/usr/include /usr/local/include"
+-COMMON_LIB_DIR="/usr/lib /usr/lib64 /usr/local/lib"
++COMMON_INCLUDE_DIR="${STAGING_INCDIR}"
++COMMON_LIB_DIR="${STAGING_LIBDIR}"
+ case $host in
+     i*86-*-linux-gnu)   COMMON_LIB_DIR="$COMMON_LIB_DIR /usr/lib/i386-linux-gnu" ;;
+     x86_64-*-linux-gnu) COMMON_LIB_DIR="$COMMON_LIB_DIR /usr/lib/x86_64-linux-gnu" ;;
diff --git a/meta-agl-bsp/openembedded-layer/recipes-support/xmlsec1/xmlsec1_1.2.%.bbappend b/meta-agl-bsp/openembedded-layer/recipes-support/xmlsec1/xmlsec1_1.2.%.bbappend
new file mode 100644 (file)
index 0000000..2d5dccd
--- /dev/null
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# 2021-08-15:
+# Fix a host contamination
+# Submitted upstream as backport from meta-oe-master
+# https://lists.openembedded.org/g/openembedded-devel/message/92583
+
+SRC_URI += "file://ensure-search-path-non-host.patch"
+