virtualization/linux-yocto: Add virtio-aarch64-standard.scc to SRC_URI. 88/26288/3
authorVasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>
Wed, 16 Dec 2020 16:47:15 +0000 (18:47 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 30 Apr 2021 16:58:41 +0000 (16:58 +0000)
It allows to use patch command to apply patches via scc file.

As explained in [1,2], Yocto kernel metadata is commonly used for two
purposes:

1. To construct Yocto kernel git by committing patches listed in scc
files.
2. To configure Yocto kernel during Yocto build.

When scc file is not explicitly added to SRC_URI, then patch commands
will be ignored during Yocto build because it is assumed that patches
are already pre-applied during Yocto kernel git tree construction.

On the other hand, nopatch should be added to standard.scc because
patches from it are actually pre-applied.

[1]: https://www.yoctoproject.org/pipermail/yocto/2019-October/046986.html
[2]: https://docs.yoctoproject.org/kernel-dev/maint-appx.html

Change-Id: Id238e79e1b354daaa23e83bef45fc93a216fbf92
Bug-AGL: SPEC-3893
Signed-off-by: Vasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26288
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto/virtio-kmeta/bsp/virtio/virtio-aarch64-standard.scc
meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_%.bbappend

index 5e613a6..e044af5 100644 (file)
@@ -2,6 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
 
 SRC_URI_append_virtio-all = " \
     file://virtio-kmeta;type=kmeta;destsuffix=virtio-kmeta \
+    file://virtio-kmeta/bsp/virtio/virtio-aarch64-${LINUX_KERNEL_TYPE}.scc \
 "
 
 COMPATIBLE_MACHINE_virtio-aarch64 = "virtio-aarch64"