Update for kirkstone variable renames
authorScott Murray <scott.murray@konsulko.com>
Tue, 22 Feb 2022 15:42:30 +0000 (10:42 -0500)
committerScott Murray <scott.murray@konsulko.com>
Wed, 30 Mar 2022 18:08:33 +0000 (14:08 -0400)
Apply updates from running the new convert-variable-renames script
from upstream, plus a few manual tweaks to the sample BB_DISKMON_DIRS
configuration in the sample local.conf files to match the changes
made in upstream.  There are a few things outside of BitBake variables
that the script still complains about that will need to be addressed
in follow up changes.

Bug-AGL: SPEC-3819

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I65e483043c1f2e48827e735cf8fdaec8d04e5fee

meta-agl-bsp/conf/include/agl_bbe.inc
meta-agl-bsp/conf/include/agl_beaglebone.inc
meta-agl-bsp/conf/include/agl_raspberrypi4.inc
meta-agl-bsp/conf/include/agl_rcar.inc
meta-agl-core-test/recipes-test/packagegroups/packagegroup-agl-test.bb
meta-agl-core/conf/local.conf.sample
scripts/.aglsetup_genconfig.bash
templates/base/01_setup_pkg_revision.sh
templates/base/local.conf.sample

index 9f9eb50..d8b24a1 100644 (file)
@@ -14,7 +14,7 @@ IMAGE_INSTALL:append = " ${PACKAGES_GFX}"
 
 # Enable Gfx Pkgs
 MACHINE_FEATURES:append = " sgx"
-MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
+BB_MULTI_PROVIDER_ALLOWED += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
 
 DEPENDS:remove = "virtual/libgl"
 
index 857a801..6a515d2 100644 (file)
@@ -9,7 +9,7 @@ IMAGE_INSTALL:append = " ${PACKAGES_GFX}"
 
 # Enable Gfx Pkgs
 MACHINE_FEATURES:append = " sgx"
-MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
+BB_MULTI_PROVIDER_ALLOWED += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
 
 DEPENDS:remove = "virtual/libgl"
 
index b497d72..3fdc68b 100644 (file)
@@ -11,7 +11,7 @@ RPI_USE_U_BOOT = "1"
 ENABLE_UART ?= "1"
 
 # For libomxil
-#LICENSE_FLAGS_WHITELIST = "commercial"
+#LICENSE_FLAGS_ACCEPTED = "commercial"
 
 IMAGE_INSTALL:append = " kernel-modules linux-firmware-rpidistro-bcm43430 linux-firmware-rpidistro-bcm43455 create-combined-dtb "
 
index 6dc40dc..7f181fc 100644 (file)
@@ -5,7 +5,7 @@ MACHINE_FEATURES:append = " agl-egvirt"
 
 # Enable Gfx Pkgs
 MACHINE_FEATURES:append = " gsx"
-MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
+BB_MULTI_PROVIDER_ALLOWED += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
 
 # for Wayland/Weston
 PREFERRED_PROVIDER_virtual/libgles1 = ""
@@ -20,7 +20,7 @@ PREFERRED_RPROVIDER_libomxil = "omx-user-module"
 PREFERRED_PROVIDER_virtual/libomxil = "omx-user-module"
 
 # Add for gstreamer plugins ugly
-LICENSE_FLAGS_WHITELIST = "commercial"
+LICENSE_FLAGS_ACCEPTED = "commercial"
 
 MACHINE_FEATURES:append = " multimedia"
 
index 57a5d32..2f45f25 100644 (file)
@@ -32,7 +32,7 @@ RDEPENDS:${PN} += "\
 
 
 
-# to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
+# to be added, but needs LICENSE_FLAGS_ACCEPTED="non-commercial"
 #    netperf                             # meta-networking
 
 # relocate due to dependencies
index 20a46ec..ecc9b14 100644 (file)
@@ -188,7 +188,7 @@ PATCHRESOLVE = "noop"
 #
 # Monitor the disk space during the build. If there is less that 1GB of space or less
 # than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
-# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
+# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard halt
 # of the build. The reason for this is that running completely out of space can corrupt
 # files and damages the build in ways which may not be easily recoverable.
 # It's necesary to monitor /tmp, if there is no space left the build will fail
@@ -198,10 +198,10 @@ BB_DISKMON_DIRS ??= "\
     STOPTASKS,${DL_DIR},1G,100K \
     STOPTASKS,${SSTATE_DIR},1G,100K \
     STOPTASKS,/tmp,100M,100K \
-    ABORT,${TMPDIR},100M,1K \
-    ABORT,${DL_DIR},100M,1K \
-    ABORT,${SSTATE_DIR},100M,1K \
-    ABORT,/tmp,10M,1K"
+    HALT,${TMPDIR},100M,1K \
+    HALT,${DL_DIR},100M,1K \
+    HALT,${SSTATE_DIR},100M,1K \
+    HALT,/tmp,10M,1K"
 
 #
 # Shared-state files from other locations
index cf06622..c7ed92e 100755 (executable)
@@ -559,12 +559,12 @@ infon "Generating setup file: $BUILDDIR/agl-init-build-env ... "
 cat <<EOF >$BUILDDIR/agl-init-build-env
 . $METADIR/external/poky/oe-init-build-env $BUILDDIR
 if [ -n "\$DL_DIR" ]; then
-       BB_ENV_EXTRAWHITE="\$BB_ENV_EXTRAWHITE DL_DIR"
+       BB_ENV_PASSTHROUGH_ADDITIONS="\$BB_ENV_PASSTHROUGH_ADDITIONS DL_DIR"
 fi
 if [ -n "\$SSTATE_DIR" ]; then
-       BB_ENV_EXTRAWHITE="\$BB_ENV_EXTRAWHITE SSTATE_DIR"
+       BB_ENV_PASSTHROUGH_ADDITIONS="\$BB_ENV_PASSTHROUGH_ADDITIONS SSTATE_DIR"
 fi
-export BB_ENV_EXTRAWHITE
+export BB_ENV_PASSTHROUGH_ADDITIONS
 unset TEMPLATECONF
 EOF
 info "OK"
index cba278d..a9e4ceb 100644 (file)
@@ -36,7 +36,7 @@ EOF
             cat <<'EOF' >> $LOCALCONF
 PKGR = "${PR}${EXTENDPRAUTO}.${AGL_PR}"
 PKGV = "${@ '${PV}'.replace('AUTOINC','${AGL_PR}')}"
-BB_HASHBASE_WHITELIST:append = " PKGR PKGV"
+BB_BASEHASH_IGNORE_VARS:append = " PKGR PKGV"
 EOF
             ;;
         value:*)
@@ -44,7 +44,7 @@ EOF
             cat <<'EOF' >> $LOCALCONF
 PKGR = "${PR}${EXTENDPRAUTO}.${AGL_PR}"
 PKGV = "${@ '${PV}'.replace('AUTOINC','${AGL_PR}')}"
-BB_HASHBASE_WHITELIST:append = " PKGR PKGV"
+BB_BASEHASH_IGNORE_VARS:append = " PKGR PKGV"
 EOF
             ;;
         none)
index 1d00448..7f2c0b1 100644 (file)
@@ -186,7 +186,7 @@ PATCHRESOLVE = "noop"
 #
 # Monitor the disk space during the build. If there is less that 1GB of space or less
 # than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
-# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
+# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard halt
 # of the build. The reason for this is that running completely out of space can corrupt
 # files and damages the build in ways which may not be easily recoverable.
 # It's necesary to monitor /tmp, if there is no space left the build will fail
@@ -196,10 +196,10 @@ BB_DISKMON_DIRS ??= "\
     STOPTASKS,${DL_DIR},1G,100K \
     STOPTASKS,${SSTATE_DIR},1G,100K \
     STOPTASKS,/tmp,100M,100K \
-    ABORT,${TMPDIR},100M,1K \
-    ABORT,${DL_DIR},100M,1K \
-    ABORT,${SSTATE_DIR},100M,1K \
-    ABORT,/tmp,10M,1K"
+    HALT,${TMPDIR},100M,1K \
+    HALT,${DL_DIR},100M,1K \
+    HALT,${SSTATE_DIR},100M,1K \
+    HALT,/tmp,10M,1K"
 
 #
 # Shared-state files from other locations