Enable ACP for HDMI on RaspberryPi4. 00/29800/5
authorAshok Sidipotu <ashok.sidipotu@collabora.com>
Thu, 4 Apr 2024 00:53:32 +0000 (02:53 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 18 Apr 2024 09:15:37 +0000 (09:15 +0000)
-HDMI dectection is broken on RaspberryPi4, Enable Pipewire-ACP to fix
it.
-copy the ACP config files as well.

Bug-AGL: SPEC-4418
Change-Id: Ice6f2a4417df56b2c00dc067590763a2c847c152
Signed-off-by: Ashok Sidipotu <ashok.sidipotu@collabora.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29800
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-pipewire/recipes-core/packagegroups/packagegroup-pipewire-base.bb
meta-pipewire/recipes-multimedia/pipewire/pipewire_1.0.0.bb
meta-pipewire/recipes-multimedia/wireplumber/wireplumber-config-agl/host.lua.d/30-alsa-monitor.lua

index 1d20b47..6237dcf 100644 (file)
@@ -13,4 +13,5 @@ RDEPENDS:${PN} += "\
     pipewire-modules-meta \
     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'pipewire-tools pipewire-spa-tools alsa-utils', '', d)} \
     pipewire-alsa \
+    pipewire-alsa-card-profile \
 "
index 641c97e..6fa851c 100644 (file)
@@ -84,7 +84,7 @@ PACKAGECONFIG ??= "\
 # is why these two are marked in their respective packageconfigs
 # as being in conflict.
 
-PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib udev"
+PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib udev,,pipewire-alsa-card-profile"
 PACKAGECONFIG[bluez] = "-Dbluez5=enabled,-Dbluez5=disabled,bluez5 sbc"
 PACKAGECONFIG[docs] = "-Ddocs=enabled,-Ddocs=disabled,doxygen-native"
 PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base"
index 75a1696..d07f7ab 100644 (file)
@@ -8,7 +8,7 @@ alsa_monitor.properties = {
 }
 
 alsa_monitor.rules = {
-  -- disable ACP (PulseAudio-like profiles)
+  -- enable ACP (PulseAudio-like profiles)
   {
     matches = {
       {
@@ -16,7 +16,7 @@ alsa_monitor.rules = {
       },
     },
     apply_properties = {
-      ["api.alsa.use-acp"] = false,
+      ["api.alsa.use-acp"] = true,
     },
   },