meta-agl-profile-core: add pyagl to agl-devel images 76/25176/3
authorScott Murray <scott.murray@konsulko.com>
Wed, 2 Sep 2020 20:24:39 +0000 (16:24 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 3 Sep 2020 16:02:41 +0000 (16:02 +0000)
Changes:
- Add recipe for pyagl, and add it as a dependency of
  packagegroup-agl-core-devel.
- Add recipes for pyagl dependencies python3-asyncssh,
  python3-pytest-dependency, and python3-pytest-reverse.
  The intent is to get these into upstream meta-python so these
  local copies can be dropped when they're available from there.

Bug-AGL: SPEC-3562

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I876ef2fffbe8724aadb23170e1ed196f05132f89
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25176
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-profile-core/recipes-devtools/packagegroups/packagegroup-agl-core-devel.bb
meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb [new file with mode: 0644]
meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb [new file with mode: 0644]
meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb [new file with mode: 0644]
meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb [new file with mode: 0644]

index 627754a..7e8f007 100644 (file)
@@ -25,4 +25,5 @@ RDEPENDS_${PN} = "\
         agl-service-network-tools \
         gcc-sanitizers \
         pciutils \
+        pyagl \
         "
diff --git a/meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb b/meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb
new file mode 100644 (file)
index 0000000..ab7e8af
--- /dev/null
@@ -0,0 +1,15 @@
+DESCRIPTION = "\
+AsyncSSH is a Python package which provides an asynchronous client and \
+server implementation of the SSHv2 protocol on top of the Python \
+asyncio framework."
+HOMEPAGE = "https://github.com/ronf/asyncssh"
+LICENSE = "EPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d9fc0efef5228704e7f5b37f27192723"
+
+SRC_URI[sha256sum] = "44bda34c7123f00c3df95d24e2dc8d43c4d17b456fbb8c434ef4f4a7ebb5265e"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-asyncio ${PYTHON_PN}-cryptography"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb b/meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb
new file mode 100644 (file)
index 0000000..5ff2d4e
--- /dev/null
@@ -0,0 +1,12 @@
+DESCRIPTION = "pytest-dependency manages dependencies of tests."
+HOMEPAGE = "https://github.com/RKrahl/pytest-dependency"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;md5=35b9938ae48d25e6b8306232e98463dd"
+
+SRC_URI[sha256sum] = "c2a892906192663f85030a6ab91304e508e546cddfe557d692d61ec57a1d946b"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-pytest-native"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb b/meta-agl-profile-core/recipes-devtools/python/python3-pytest-reverse_1.0.1.bb
new file mode 100644 (file)
index 0000000..5ed9b1d
--- /dev/null
@@ -0,0 +1,12 @@
+DESCRIPTION = "pytest-reverse is a pytest plugin to reverse test order"
+HOMEPAGE = "https://github.com/adamchainz/pytest-reverse"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=caf1f407ae86ecd57ab721dff94079b7"
+
+SRC_URI[sha256sum] = "40cbc47df8a262fed778e500f4d0b17d2d08ef8b9fbf899c0bab9488be192aac"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-pytest-native"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb b/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
new file mode 100644 (file)
index 0000000..770fdac
--- /dev/null
@@ -0,0 +1,29 @@
+SUMMARY = "Python bindings and tests for Automotive Grade Linux services"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/pyagl"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/pyagl;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "f583233db298a709a813d8c0af97769ba30ae002"
+PV = "${AGL_BRANCH}+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS_${PN} += " \
+    python3-asyncio \
+    python3-asyncssh \
+    python3-core \
+    python3-json \
+    python3-logging \
+    python3-math \
+    python3-parse \
+    python3-pprint \
+    python3-pytest \
+    python3-pytest-asyncio \
+    python3-pytest-dependency \
+    python3-pytest-reverse \
+    python3-typing \
+    python3-websockets \
+"