meta-app-framework: recipes-core: add applaunchd recipe 15/27015/2
authorArnaud Ferraris <arnaud.ferraris@collabora.com>
Fri, 17 Dec 2021 09:43:20 +0000 (10:43 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 17 Dec 2021 21:15:26 +0000 (21:15 +0000)
Bug-AGL: SPEC-4160
Signed-off-by: Arnaud Ferraris <arnaud.ferraris@collabora.com>
Change-Id: I7b2d5e660625091d665727d48a45eb1b7958904e
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27015
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb [new file with mode: 0644]

diff --git a/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb b/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
new file mode 100644 (file)
index 0000000..70af49b
--- /dev/null
@@ -0,0 +1,28 @@
+SUMMARY     = "AGL Application Launcher service"
+DESCRIPTION = "AGL Application Launcher service build with recipe method"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/src/applaunchd"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+    glib-2.0 \
+    glib-2.0-native \
+"
+
+PV      = "1.0+git${SRCPV}"
+
+SRC_URI = " \
+        git://gerrit.automotivelinux.org/gerrit/src/applaunchd;protocol=https;branch=${AGL_BRANCH}  \
+        "
+SRCREV = "${AGL_APP_REVISION}"
+
+S       = "${WORKDIR}/git"
+
+inherit meson pkgconfig
+
+FILES:${PN} += " ${datadir}/dbus-1/"
+
+RDEPENDS:${PN} += " \
+    agl-session \
+"