Fix reproducability issue reported by YP autobuilder 81/27781/3
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 19 Jul 2022 21:32:16 +0000 (23:32 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 20 Jul 2022 14:12:44 +0000 (14:12 +0000)
The main issue was the rewrite of CFLAGS that resulted in missing flags,
namely the DEBUG_PREFIX_MAP.

Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: Ie4f939f4cb17ab13c6dc59b8d4c122f86d26b006
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27781
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses/0001-Do-not-overwrite-CFLAGS.patch [new file with mode: 0644]
meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses/0001-Initialize-variables.patch [new file with mode: 0644]
meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb

diff --git a/meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses/0001-Do-not-overwrite-CFLAGS.patch b/meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses/0001-Do-not-overwrite-CFLAGS.patch
new file mode 100644 (file)
index 0000000..4a86e6c
--- /dev/null
@@ -0,0 +1,37 @@
+From 50ca6e010c3ca3f7cb06dfdf5dbdfaacd4f4749a Mon Sep 17 00:00:00 2001
+From: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
+Date: Tue, 19 Jul 2022 23:28:21 +0200
+Subject: [PATCH] Do not overwrite CFLAGS
+
+Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
+---
+ configure.ac | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 7e3307f..c385bc0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -24,14 +24,14 @@ AC_PROG_CC
+ AC_PROG_CC_C99
+ AM_PROG_CC_C_O
+-CFLAGS=""
+-
+-AC_ARG_ENABLE(optimization, AC_HELP_STRING([--disable-optimization],
+-                      [disable code optimization through compiler]), [
+-      if (test "${enableval}" = "no"); then
+-              CFLAGS="$CFLAGS -O0 -U_FORTIFY_SOURCE"
+-      fi
+-])
++#CFLAGS=""
++#
++#AC_ARG_ENABLE(optimization, AC_HELP_STRING([--disable-optimization],
++#                     [disable code optimization through compiler]), [
++#     if (test "${enableval}" = "no"); then
++#             CFLAGS="$CFLAGS -O0 -U_FORTIFY_SOURCE"
++#     fi
++#])
+ AC_ARG_ENABLE(debug, AC_HELP_STRING([--enable-debug],
+                       [enable compiling with debugging information]), [
diff --git a/meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses/0001-Initialize-variables.patch b/meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses/0001-Initialize-variables.patch
new file mode 100644 (file)
index 0000000..9a10784
--- /dev/null
@@ -0,0 +1,39 @@
+From 0389a80796d3ae31d8f60659f0638660a00157b2 Mon Sep 17 00:00:00 2001
+From: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
+Date: Tue, 19 Jul 2022 23:58:05 +0200
+Subject: [PATCH] Initialize variables
+
+This fixes compiler warnings.
+
+Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
+---
+ main.c      | 2 +-
+ renderers.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/main.c b/main.c
+index f0354f9..1fa9ab1 100644
+--- a/main.c
++++ b/main.c
+@@ -159,7 +159,7 @@ static void report_error()
+  */
+ static void get_help_window()
+ {
+-      char *msg;
++      char *msg = "";
+       if (win_help)
+               return;
+diff --git a/renderers.c b/renderers.c
+index c531a1e..d9d0414 100644
+--- a/renderers.c
++++ b/renderers.c
+@@ -153,7 +153,7 @@ static void renderers_technologies(struct json_object *jobj)
+       int i;
+       char *desc_base = "%-20s Powered %-5s          Connected %-5s";
+       char desc_base_sub[30];
+-      const char *k_name, *k_type, *k_powered, *k_connected;
++      const char *k_name = "" , *k_type = "" , *k_powered = "", *k_connected = "";
+       char *desc, *tech_short_name;
+       struct json_object *sub_array, *dbus_tech_name, *tech_dict;
+       struct userptr_data *data;
index 0d1983d..7b6d505 100644 (file)
@@ -10,13 +10,15 @@ LICENSE = "GPL-2.0-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=8c16666ae6c159876a0ba63099614381"
 
 SRC_URI = "git://gitlab.com/iotbzh/connman-json-client.git;protocol=https;branch=master \
-           file://stdbool-fixes.patch"
+           file://stdbool-fixes.patch \
+           file://0001-Do-not-overwrite-CFLAGS.patch \
+           file://0001-Initialize-variables.patch \
+           "
 SRCREV = "2b0f93ec9518c978c04807fe52e95315d6d80e6b"
 
 inherit autotools pkgconfig
 
-EXTRA_AUTORECONF += " -i"
-EXTRA_OECONF += " --disable-optimization --enable-debug"
+EXTRA_AUTORECONF += " -vfi"
 
 S = "${WORKDIR}/git"