af-main: Use xdg-shell-v6 for agl-compositor 19/23619/2
authorMarius Vlad <marius.vlad@collabora.com>
Thu, 23 Jan 2020 16:49:23 +0000 (18:49 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 28 Jan 2020 16:36:56 +0000 (16:36 +0000)
As we're using xdg-shell-v6 instead of ivi-shell for agl-compositor and
applications, make the transition much easier (that is, having a fully bootable
workable image) by making it default when the DISTRO_FEATURES specify it.

Bug-AGL: SPEC-3128

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: I1bf1546d3cfab14b1b4b76199ba60207c984d69f

meta-app-framework/recipes-core/af-main/af-main_git.bb

index 6e44c49..66b93db 100644 (file)
@@ -85,7 +85,9 @@ do_install_append_class-target() {
         ln -sf ../afm-system-daemon.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-system-daemon.service
         ln -sf ../afm-system-daemon.socket ${D}${systemd_system_unitdir}/sockets.target.wants/afm-system-daemon.socket
     fi
-    echo "QT_WAYLAND_SHELL_INTEGRATION=ivi-shell" > ${D}${afm_confdir}/unit.env.d/qt-for-ivi-shell
+
+    DEFAULT_WM_SHELL="${@bb.utils.contains('DISTRO_FEATURES', 'agl-compositor', 'xdg-shell-v6', 'ivi-shell', d)}"
+    echo "QT_WAYLAND_SHELL_INTEGRATION=${DEFAULT_WM_SHELL}" > ${D}${afm_confdir}/unit.env.d/qt-shell
 }
 
 pkg_postinst_ontarget_${PN}() {