Fix the recipe of weston 55/4455/2
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Fri, 11 Dec 2015 08:01:05 +0000 (17:01 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 11 Dec 2015 17:08:48 +0000 (17:08 +0000)
To suit systemd.bbclass and poky-agl.conf, recipe of weston has
been fixed.

Change-Id: I9b401748176d0afdf5f8566b6e126416bb9d79d8
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
meta-agl/recipes-graphics/wayland/weston_1.5.0.bbappend

index c982ed5..7167388 100644 (file)
@@ -8,13 +8,15 @@ SRC_URI_append = "\
     "
 
 inherit systemd
-DEPENDS_append = " systemd"
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "weston.service"
 
 do_install_append() {
-    mkdir -p ${D}${systemd_unitdir}/system/
-    cp ${WORKDIR}/weston.service ${D}${systemd_unitdir}/system/
-    mkdir -p ${D}${systemd_unitdir}/system/multi-user.target.wants/
-    ln -sf /lib/systemd/system/weston.service ${D}/${systemd_unitdir}/system/multi-user.target.wants/weston.service
+    # Install systemd unit files
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+        install -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
+    fi
 
     WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
     install -d ${D}${WESTON_INI_CONFIG}
@@ -22,6 +24,5 @@ do_install_append() {
 }
 
 FILES_${PN} += " \
-    ${systemd_unitdir}/system/* \
     ${sysconfdir}/xdg/weston/weston.ini \
     "