Replace "/etc" with "${sysconfidir}" 79/27479/3
authorduerpei <duep.fnst@fujitsu.com>
Mon, 16 May 2022 03:10:07 +0000 (11:10 +0800)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 16 May 2022 12:10:15 +0000 (12:10 +0000)
make them more standardized

Bug-AGL: SPEC-4374

Signed-off-by: duerpei <duep.fnst@fujitsu.com>
Change-Id: Ie11168254ab76acd11382b33501fb4881710a5bf
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27479
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb

index 3f497a1..86e3534 100644 (file)
@@ -13,6 +13,6 @@ SYSTEMD_SERVICE:${PN} = "pvr.service"
 do_install:append() {
        install -d ${D}${systemd_system_unitdir}
        install -m 0755 ${WORKDIR}/pvr.service ${D}${systemd_system_unitdir}
-       install -d ${D}/etc/ti-sgx
-       install -m 0755 ${D}/etc/init.d/rc.pvr ${D}/etc/ti-sgx
+       install -d ${D}${sysconfdir}/ti-sgx
+       install -m 0755 ${D}${sysconfdir}/init.d/rc.pvr ${D}${sysconfdir}/ti-sgx
 }
index 1e3ae7f..dd61a1e 100644 (file)
@@ -8,8 +8,8 @@ S = "${WORKDIR}"
 RDEPENDS:${PN} += "nbd-client"
 
 do_install() {
-       install -dm 0755 ${D}/etc
-       touch ${D}/etc/initrd-release
+       install -dm 0755 ${D}${sysconfdir}
+       touch ${D}${sysconfdir}/initrd-release
        install -dm 0755 ${D}/dev
        install -dm 0755 ${D}${sbindir}
        install -m 0755 ${WORKDIR}/init.sh ${D}${sbindir}/init
@@ -17,5 +17,5 @@ do_install() {
 
 inherit allarch
 
-FILES:${PN} += " /dev /etc/initrd-release ${sbindir}/init "
+FILES:${PN} += " /dev ${sysconfdir}/initrd-release ${sbindir}/init "