tests: Add new recipe for linus_stress 39/5639/3
authorYannick Gicquel <yannick.gicquel@iot.bzh>
Tue, 10 May 2016 10:08:10 +0000 (12:08 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 19 Jun 2016 19:38:57 +0000 (19:38 +0000)
Change-Id: Ia8661e982daa09da3e85287e8323690c1b079322
Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
meta-ivi-common/recipes-test/linus-stress/linus-stress.bb [new file with mode: 0644]

diff --git a/meta-ivi-common/recipes-test/linus-stress/linus-stress.bb b/meta-ivi-common/recipes-test/linus-stress/linus-stress.bb
new file mode 100644 (file)
index 0000000..0d1a9e6
--- /dev/null
@@ -0,0 +1,22 @@
+SUMMARY = "linus_stress test"
+HOMEPAGE = "https://chromium.googlesource.com/chromiumos/third_party/autotest/+/master/client/tests/linus_stress"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${S}/linus_stress/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=master"
+SRCREV = "87cdfd4626c0cb47fc22f328867e49d6268df85c"
+
+inherit autotools
+
+B = "${WORKDIR}/git/linus_stress"
+S = "${WORKDIR}/git"
+
+# configure script is not delivered, only a makefile.
+do_configure() {
+    :
+}
+
+do_install() {
+    install -d ${D}${bindir}
+    install -m 0755 ${B}/linus_stress ${D}${bindir}
+}