Add a minimal set of packages for GStreamer1.0 62/4062/3
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Mon, 31 Aug 2015 09:50:24 +0000 (18:50 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 2 Sep 2015 11:22:53 +0000 (11:22 +0000)
This configuration is for installing a minimal set of packages
to use GStreamer1.0 in meta-agl.

This configuration also switch 2 versions of GStreamer,
when building for QEMU, GStreamer1.0 1.4.1 is selected by AGL distro
configuration, for R-Car2 Porter, GStreamer1.0 1.2.3 by meta-renesas.

The installed plugins of GStreamer1.0 is also minimal, so when more
are needed, add appropriate packages to IMAGE_INSTALL in your
local.conf manually.

Change-Id: I379e75f2eaacd47e80ceafdb00e2dcfaeda0db1f
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
meta-agl/conf/distro/poky-agl.conf
meta-agl/conf/local.conf.sample
meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-multimedia.bb

index 7b1f61d..b7a8138 100644 (file)
@@ -30,6 +30,15 @@ PREFERRED_VERSION_linux-yocto_qemuarm ?= "3.14%"
 # PREFERRED_VERSION_linux-yocto_qemumips64 ?= "3.14%"
 # PREFERRED_VERSION_linux-yocto_qemuppc ?= "3.14%"
 
+# Prefer GStreamer 1.4.x by default
+PREFERRED_VERSION_gstreamer1.0              ?= "1.4.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-bad  ?= "1.4.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-base ?= "1.4.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-good ?= "1.4.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-ugly ?= "1.4.%"
+PREFERRED_VERSION_gstreamer1.0-libav        ?= "1.4.%"
+PREFERRED_VERSION_gstreamer1.0-omx          ?= "1.2.%"
+
 SDK_NAME = "${DISTRO}-${TCLIBC}-${SDK_ARCH}-${IMAGE_BASENAME}-${TUNE_PKGARCH}"
 SDKPATH = "/opt/${DISTRO}/${SDK_VERSION}"
 
index 5c3e840..dd0207b 100644 (file)
@@ -2,11 +2,11 @@
 # This file is your local configuration file and is where all local user settings
 # are placed. The comments in this file give some guide to the options a new user
 # to the system might want to change but pretty much any configuration option can
-# be set in this file. More adventurous users can look at local.conf.extended 
+# be set in this file. More adventurous users can look at local.conf.extended
 # which contains other examples of configuration which can be placed in this file
 # but new users likely won't need any of them initially.
 #
-# Lines starting with the '#' character are commented out and in some cases the 
+# Lines starting with the '#' character are commented out and in some cases the
 # default values are provided as comments to show people example syntax. Enabling
 # the option is a question of removing the # character and making any change to the
 # variable as required.
@@ -23,7 +23,7 @@
 #MACHINE ?= "qemux86"
 #MACHINE ?= "qemux86-64"
 #
-# There are also the following hardware board target machines included for 
+# There are also the following hardware board target machines included for
 # demonstration purposes:
 #
 #MACHINE ?= "beaglebone"
@@ -81,12 +81,13 @@ MACHINE ??= "qemux86-64"
 #
 # The distribution setting controls which policy settings are used as defaults.
 # The default value is fine for general Yocto project use, at least initially.
-# Ultimately when creating custom policy, people will likely end up subclassing 
+# Ultimately when creating custom policy, people will likely end up subclassing
 # these defaults.
 #
-DISTRO ?= "poky"
+#DISTRO ?= "poky"
+DISTRO ?= "poky-agl"
 # As an example of a subclass there is a "bleeding" edge policy configuration
-# where many versions are set to the absolute latest code from the upstream 
+# where many versions are set to the absolute latest code from the upstream
 # source control systems. This is just mentioned here as an example, its not
 # useful to most new users.
 # DISTRO ?= "poky-bleeding"
@@ -94,8 +95,8 @@ DISTRO ?= "poky"
 #
 # Package Management configuration
 #
-# This variable lists which packaging formats to enable. Multiple package backends 
-# can be enabled at once and the first item listed in the variable will be used 
+# This variable lists which packaging formats to enable. Multiple package backends
+# can be enabled at once and the first item listed in the variable will be used
 # to generate the root filesystems.
 # Options are:
 #  - 'package_deb' for debian style deb files
@@ -163,8 +164,8 @@ USER_CLASSES ?= "buildstats image-mklibs image-prelink"
 #
 # Interactive shell configuration
 #
-# Under certain circumstances the system may need input from you and to do this it 
-# can launch an interactive shell. It needs to do this since the build is 
+# Under certain circumstances the system may need input from you and to do this it
+# can launch an interactive shell. It needs to do this since the build is
 # multithreaded and needs to be able to handle the case where more than one parallel
 # process may require the user's attention. The default is iterate over the available
 # terminal types to find one that works.