Update SRCREV for agl-compositor 93/24393/1
authorMarius Vlad <marius.vlad@collabora.com>
Mon, 20 Apr 2020 16:51:12 +0000 (19:51 +0300)
committerMarius Vlad <marius.vlad@collabora.com>
Mon, 20 Apr 2020 16:57:08 +0000 (19:57 +0300)
This brings up two major bits of functionality: the introduction of the
agl-shell-desktop protocol, which should be used by regular
application(s) to activate/switch other to other applications, and
the introduction of the policy API and with it, a default allow-all
kind of policy engine.

In more details, the following changes have been included:

fcd71e034d378921e layout: Mark activated surface by default
1ee1bff64338dede1 desktop: Remove the active surface only if matches the one being displayed
0e66ee13b73e3ca21 meson.build: Increase the build version of agl-compositor
721d4d4f73e5d30ce README.md: Start adding some light documentation on the policy part
0a932bc7d66b062e6 layout: Allow by default to activate the application
58a3fe5c292349916 policy-default: Install a default policy engine
98457c49f5d777e40 policy: Init policy framework API
fe3358fa9b560a43e ivi-compositor: Use the helpers for array length
6491e204fd4a9bd2d meson.build: Do another agl-compositor version bump
72aa326d8f54ad75c meson.build: Install agl-shell-desktop extension
786f91bd280b83049 protocol: Advertise the applications to regular clients
a35a7f2e5cc20bd40 protocol: Add agl-shell-desktop protocol

This patch also installs the agl-shell-desktop XML file.

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: Icaec7e375242a0266383523806e5eca40d75b652

meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb

index 20a78f7..c885654 100644 (file)
@@ -11,11 +11,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
 DEPENDS = "wayland wayland-protocols wayland-native weston"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "dbba1adda7fd9aaaa46263d8c878132a523327e4"
+SRCREV = "fcd71e034d378921e0408a69dedcd8d0f4836401"
 
 PV = "0.0.10+git${SRCPV}"
 S = "${WORKDIR}/git"
 
 inherit meson pkgconfig python3native
 
-FILES_${PN} = "${bindir}/agl-compositor ${datadir}/${PN}/protocols/agl-shell.xml"
+FILES_${PN} = "${bindir}/agl-compositor ${datadir}/${PN}/protocols/agl-shell.xml ${datadir}/${PN}/protocols/agl-shell-desktop.xml"