meta-netboot: enable NBD and Ramdisk support in kernel config 29/5829/3
authorStephane Desneux <stephane.desneux@iot.bzh>
Wed, 8 Jun 2016 15:31:21 +0000 (15:31 +0000)
committerGerrit Code Review <gerrit@172.30.200.200>
Sun, 19 Jun 2016 19:25:27 +0000 (19:25 +0000)
NBD and Ramdisk support are required in the kernel to have
the root filesystem mounted as an NBD device:

* ramdisk is required to load the initrd (not an initramfs)
* NBD is required to mount the root device from a remote NBD server

Change-Id: Ib726714adfb549eaeb21f96e7bf874290e700a8b
Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
meta-netboot/recipes-kernel/linux/files/nbd.cfg [new file with mode: 0644]
meta-netboot/recipes-kernel/linux/files/ramdisk.cfg [new file with mode: 0644]
meta-netboot/recipes-kernel/linux/linux-yocto_%.bbappend [new file with mode: 0644]

diff --git a/meta-netboot/recipes-kernel/linux/files/nbd.cfg b/meta-netboot/recipes-kernel/linux/files/nbd.cfg
new file mode 100644 (file)
index 0000000..af37685
--- /dev/null
@@ -0,0 +1 @@
+CONFIG_BLK_DEV_NBD=y
diff --git a/meta-netboot/recipes-kernel/linux/files/ramdisk.cfg b/meta-netboot/recipes-kernel/linux/files/ramdisk.cfg
new file mode 100644 (file)
index 0000000..41530dd
--- /dev/null
@@ -0,0 +1 @@
+CONFIG_BLK_DEV_RAM=y
diff --git a/meta-netboot/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-netboot/recipes-kernel/linux/linux-yocto_%.bbappend
new file mode 100644 (file)
index 0000000..88f2441
--- /dev/null
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# Extra configuration options for NBD support and netboot over RAMFS
+SRC_URI += "file://nbd.cfg \
+            file://ramdisk.cfg \
+            "