meta-app-framework: add af-main-tools and dependencies in nativesdk-packagegroup...
authorStephane Desneux <stephane.desneux@iot.bzh>
Fri, 8 Jul 2016 15:08:25 +0000 (15:08 +0000)
committerStephane Desneux <stephane.desneux@iot.bzh>
Mon, 27 Mar 2017 13:33:39 +0000 (15:33 +0200)
This is required to install app framework sdk tools.

Change-Id: Iad407420fa734c063926d1883c288af387155668
Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
meta-app-framework/recipes-core/af-main/af-main_1.0.bb
meta-app-framework/recipes-core/af-main/af-main_1.0.inc [new file with mode: 0644]
meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb [new file with mode: 0644]
meta-app-framework/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend [new file with mode: 0644]
meta-app-framework/recipes-support/xmlsec1/xmlsec1_1.%.bbappend

index 5bcfdf9..75cdcc3 100644 (file)
@@ -1,3 +1,5 @@
+require af-main_${PV}.inc 
+
 # NOTE: using libcap-native and setcap in install doesn't work
 # NOTE: there is no SYSTEMD_USER_SERVICE_...
 # NOTE: maybe setting afm_name to agl-framework is cleaner but has implications
@@ -6,28 +8,8 @@
 
 inherit cmake pkgconfig useradd systemd
 
-SUMMARY = "AGL Framework Main part"
-DESCRIPTION = "\
-This is a core framework component for managing \
-applications, widgets, and components. \
-"
-
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-main"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=master"
-SRC_URI_files = ""
-SRC_URI = "${SRC_URI_git} \
-           ${SRC_URI_files} \
-          "
-
-SRCREV = "81df68c04dc5e32d5d6d06bc20a7030afdf45f59"
-
 SECTION = "base"
 
-S = "${WORKDIR}/git"
-
 DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c security-manager libcap-native af-binder"
 
 afm_name    = "afm"
@@ -38,6 +20,7 @@ afb_binding_dir = "${libdir}/afb"
 EXTRA_OECMAKE = "\
        -DUSE_LIBZIP=1 \
        -DUSE_SIMULATION=0 \
+       -DUSE_SDK=0 \
        -Dafm_name=${afm_name} \
        -Dafm_confdir=${afm_confdir} \
        -Dafm_datadir=${afm_datadir} \
@@ -91,5 +74,3 @@ PACKAGES =+ "${PN}-tools ${PN}-tools-dbg"
 FILES_${PN}-tools = "${bindir}/wgtpkg-*"
 FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
 
-BBCLASSEXTEND = "native nativesdk"
-
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
new file mode 100644 (file)
index 0000000..6880754
--- /dev/null
@@ -0,0 +1,20 @@
+SUMMARY = "AGL Framework Main part"
+DESCRIPTION = "\
+This is a core framework component for managing \
+applications, widgets, and components. \
+"
+
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-main"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=master"
+SRC_URI_files = ""
+SRC_URI = "${SRC_URI_git} \
+           ${SRC_URI_files} \
+          "
+
+SRCREV = "0257e4d58a25d328a971423d5fe5289d9985d046"
+
+S = "${WORKDIR}/git"
+
diff --git a/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb
new file mode 100644 (file)
index 0000000..426e999
--- /dev/null
@@ -0,0 +1,25 @@
+require af-main_${PV}.inc 
+
+inherit nativesdk cmake pkgconfig 
+
+SECTION = "base"
+
+DEPENDS = "nativesdk-openssl nativesdk-libxml2 nativesdk-xmlsec1 nativesdk-libzip"
+
+afm_name    = "afm"
+afm_confdir = "${sysconfdir}/${afm_name}"
+afm_datadir = "${datadir}/${afm_name}"
+
+EXTRA_OECMAKE = "\
+       -DUSE_LIBZIP=1 \
+       -DUSE_SIMULATION=1 \
+       -DUSE_SDK=1 \
+       -Dafm_name=${afm_name} \
+       -Dafm_confdir=${afm_confdir} \
+       -Dafm_datadir=${afm_datadir} \
+"
+
+PACKAGES = "${PN}-tools ${PN}-tools-dbg"
+FILES_${PN}-tools = "${bindir}/wgtpkg-* ${afm_confdir}/*"
+FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
+
diff --git a/meta-app-framework/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend b/meta-app-framework/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
new file mode 100644 (file)
index 0000000..ca0b54f
--- /dev/null
@@ -0,0 +1,2 @@
+RDEPENDS_${PN} =+ "nativesdk-af-main-tools"
+
index 539a88f..8f1972f 100644 (file)
@@ -2,3 +2,5 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
 SRC_URI += "file://Only-require-libxslt-in-.pc-files-when-necessary.patch"
 
 DEPENDS += "libxml2"
+
+BBCLASSEXTEND = "native nativesdk"