Fix template for s4 and adapt kernel recipe 44/29744/5
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 18 Mar 2024 19:27:26 +0000 (20:27 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 25 Mar 2024 20:39:12 +0000 (20:39 +0000)
The template needs meta-python present and the
kernel recipe does try to install a firmware file
that is not packaged. Remove that.

Bug-AGL: SPEC-5101
Change-Id: I3fdb860df04ee90e3e3b30875ea4f9494b15dbf0
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29744
Tested-by: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
ci-image-build: Jenkins Job builder account

meta-agl-bsp/meta-rcar-gateway/recipes-kernel/linux/linux-renesas_%.bbappend [new file with mode: 0644]
templates/machine/s4sk/50_bblayers.conf.inc

diff --git a/meta-agl-bsp/meta-rcar-gateway/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-agl-bsp/meta-rcar-gateway/recipes-kernel/linux/linux-renesas_%.bbappend
new file mode 100644 (file)
index 0000000..d565da8
--- /dev/null
@@ -0,0 +1,11 @@
+do_install:append () {
+
+    # Remove firmware file that is not packaged in the kernel.
+    # It throws an error during do_package.
+    # It seems to be moved out of the kernel in later BSP versions.
+    rm -rf ${D}/lib/firmware/r8a779f0_ufs.bin
+    rm -rf ${D}/lib/firmware
+    rm -rf ${D}/lib
+
+}
+
index 0095dbc..0cc25a9 100644 (file)
@@ -2,3 +2,6 @@ BBLAYERS =+ "\
   ${METADIR}/bsp/meta-renesas/meta-rcar-gateway \
   ${METADIR}/external/poky/meta-yocto-bsp \
   "
+
+AGL_META_PYTHON = "${METADIR}/external/meta-openembedded/meta-python"
+