[wic] race condition: do not update the fstab 87/25387/2
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 12 Oct 2020 18:53:52 +0000 (20:53 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 15 Oct 2020 09:34:45 +0000 (09:34 +0000)
do_image_wic will run in parallel with other jobs
in the current codebase of OE. Then these other
jobs might get the wrong content for
/etc/fstab that is modified by do_image_wic.

To prevent this behaviour, disable the modification in wic.

NOTE: This might have consequences on custom or complex
wks files. Thus allow the user to override this.

Bug-AGL: SPEC-3621
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: I03cb589fb592c1d7e0ccfff54535b91ba73974be
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25412
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Scott Murray <scott.murray@konsulko.com>
(cherry picked from commit 6d46b8cb03890d899af2bf6e5222dc0954836c90)
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25387

meta-agl-distro/conf/distro/poky-agl.conf

index c21eee1..c3abdec 100644 (file)
@@ -196,3 +196,12 @@ PREFERRED_RPROVIDER_virtual/low-can-dev-mapping ?= "dev-mapping"
 # support. Not having it is not an issue, since there is also explicit
 # enabling of required security features done by meta-agl/meta-security.
 BBMASK += "meta-security/recipes-kernel/linux/linux-%_5.%.bbappend"
+
+# Workaround for https://jira.automotivelinux.org/browse/SPEC-3621
+# TLDR: do_image_wic will modify the target's /etc/fstab while
+# do_image_tar and do_image_ext4 can run in parallel
+# This needs to be fixed upstream:
+# See https://bugzilla.yoctoproject.org/show_bug.cgi?id=13994
+# For convenience restricted to ext4 and tar image types.
+AGL_FORBID_FSTAB_UPDATE ?= "${@bb.utils.contains_any('IMAGE_FSTYPES', 'ext4 ext4.xz tar tar.gz tar.bz2 tar.xz', '--no-fstab-update', '', d)}"
+WIC_CREATE_EXTRA_ARGS_append = " ${AGL_FORBID_FSTAB_UPDATE}"