libsdl2: PACKAGECONFIG tweaks 92/28192/3
authorScott Murray <scott.murray@konsulko.com>
Wed, 23 Nov 2022 21:33:29 +0000 (16:33 -0500)
committerScott Murray <scott.murray@konsulko.com>
Thu, 8 Dec 2022 06:48:59 +0000 (06:48 +0000)
Add a couple of bbappends for libsdl2 to tweak its PACKAGECONFIG,
based on Panasonic QEMU+KVM documentation.

Bug-AGL: SPEC-4618

Change-Id: I7ceb4e46faa88f09311ad359a3b0b13a462f6cb2
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28192
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account

meta-agl-core/recipes-graphics/libsdl2/libsdl2_%.bbappend [new file with mode: 0644]
meta-agl-core/recipes-graphics/libsdl2/libsdl2_aglcore.inc [new file with mode: 0644]

diff --git a/meta-agl-core/recipes-graphics/libsdl2/libsdl2_%.bbappend b/meta-agl-core/recipes-graphics/libsdl2/libsdl2_%.bbappend
new file mode 100644 (file)
index 0000000..48e5078
--- /dev/null
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'aglcore', 'libsdl2_aglcore.inc', '', d)}
diff --git a/meta-agl-core/recipes-graphics/libsdl2/libsdl2_aglcore.inc b/meta-agl-core/recipes-graphics/libsdl2/libsdl2_aglcore.inc
new file mode 100644 (file)
index 0000000..7652e18
--- /dev/null
@@ -0,0 +1,3 @@
+# Make sure opengl is disabled, as using wayland implies gles2 in the
+# libsdl2 PACKAGECONFIG definitions.
+PACKAGECONFIG:remove = "opengl"