AMB (automotive-message-broker): enable gpsnmea plugin 29/4429/2
authorManuel Bachmann <mbc@iot.bzh>
Tue, 8 Dec 2015 03:35:43 +0000 (03:35 +0000)
committerGerrit Code Review <gerrit@172.30.200.200>
Tue, 8 Dec 2015 20:08:52 +0000 (20:08 +0000)
In this version of AMB, GPS plugin is named "gpsnmea" and
does not really depend on gpsd, so fix the build option and
remove the dependency.

If gpsnmea is enabled (default), we should ship a matching
configuration file so that it gets loaded automatically.
Consider an USB GPS device ; at worst, if no device is
present, harmless NULL values will be returned by AMB.

Change-Id: I60fc960bff04b334a2556b9ec92a4089398d453e
Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker/gps [new file with mode: 0644]
meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc

diff --git a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker/gps b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker/gps
new file mode 100644 (file)
index 0000000..be8e52e
--- /dev/null
@@ -0,0 +1,7 @@
+{
+       "name" : "gpsnmea",
+       "path" : "/usr/lib//automotive-message-broker/gpsnmea.so",
+       "device" : "/dev/ttyUSB0",
+       "baudrate" : "4800",
+       "enabled" : true
+}
index 4873f12..2894b2c 100644 (file)
@@ -16,7 +16,7 @@ RDEPENDS_${PN} = "python-misc python-json"
 PACKAGECONFIG ??= " use_gps \
     ${@bb.utils.contains('BBFILE_COLLECTIONS','qt5-layer','use_qt5','', d)} \
     "
-PACKAGECONFIG[use_gps] = "-Dgpsd_plugins=On,,gpsd"
+PACKAGECONFIG[use_gps] = "-Dgpsnmea_plugin=On"
 PACKAGECONFIG[use_qt5] = "-Dqtmainloop=On -Dqt_bindings=On,,qtbase qtdeclarative"
 
 SYSTEMD_PACKAGES = "${PN}"
@@ -33,6 +33,10 @@ do_install_append() {
 
     install -d ${D}${systemd_unitdir}/system/
     install -m 0644 ${WORKDIR}/ambd.service ${D}${systemd_unitdir}/system
+
+    if [ "${@bb.utils.contains('PACKAGECONFIG', 'use_gps', 'use_gps', '', d)}" = "use_gps" ]; then
+        install -m 0644 ${WORKDIR}/gps ${D}/${sysconfdir}/ambd/plugins.d
+    fi
 }
 
 FILES_${PN} += " ${systemd_unitdir}/ambd.service \
index 9cef0d5..377e9eb 100644 (file)
@@ -21,6 +21,7 @@ SRC_URI += " \
     file://0009-Add-Pressure-property-to-BrakeOperation.patch \
     file://0001-Fix-build-issues-while-bitbake-without-meta-qt5-laye.patch \
     file://ambd.service \
+    file://gps \
     "
 
 S = "${WORKDIR}/git"