Fix orientation for dual-hdmi setup on pi4 84/28984/2
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 4 Jun 2023 20:37:40 +0000 (22:37 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 5 Jun 2023 08:27:59 +0000 (08:27 +0000)
The weston-ini-conf was not ready for dual-screen setup.
Fix it.

Bug-AGL: SPEC-4822

Change-Id: I75d8810fb9e58aadeceabeadf44ceedff4749d6e
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28984
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-dual.cfg [new file with mode: 0644]

index 5f8af21..9e50a75 100644 (file)
@@ -1,3 +1,7 @@
 FILESEXTRAPATHS:prepend:raspberrypi := "${THISDIR}/${PN}:"
 
-SRC_URI:append:raspberrypi = " file://dsi.cfg"
+# OLD DSI config
+#SRC_URI:append:raspberrypi = " file://dsi.cfg"
+
+# two hdmi ports
+SRC_URI:append:raspberrypi = " file://hdmi-dual.cfg"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-dual.cfg b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-dual.cfg
new file mode 100644 (file)
index 0000000..61d1362
--- /dev/null
@@ -0,0 +1,9 @@
+# Support the Raspberry Pi Foundation 7" tablet which uses the DSI connector
+# rather than HDMI.
+[output]
+name=HDMI-A-1
+transform=rotate-90
+
+[output]
+name=HDMI-A-2
+transform=rotate-90