agl-compositor: Move protocol files to the -dev package 90/26490/8
authorMarius Vlad <marius.vlad@collabora.com>
Thu, 8 Jul 2021 15:18:22 +0000 (17:18 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 13 Jul 2021 11:42:33 +0000 (11:42 +0000)
Bug-AGL: SPEC-4015

v2 (jsmoeller): simplify protocols recipe
v3 (jsmoeller): pkgconfig needs to be in the protocols package
v4 (mvlad): Re-phrase the commit description
v5 (mvlad): leave DEPENDS alone
v6 (smurray): Untagle commit message

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: I21fa9b40ad07871b956abcbb4e79c8f5d742522c
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26490
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jenkins Job builder account
meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb

index 87df04e..cdc781a 100644 (file)
@@ -24,9 +24,13 @@ PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
 inherit meson pkgconfig python3native
 
 FILES_${PN} = " \
-               ${bindir}/agl-compositor \
-               ${bindir}/agl-screenshooter \
-               ${datadir}/${PN}/protocols/agl-shell.xml \
-               ${datadir}/${PN}/protocols/agl-shell-desktop.xml \
-              "
+    ${bindir}/agl-compositor \
+    ${bindir}/agl-screenshooter \
+"
+
 RDEPENDS_${PN} += " ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
+
+FILES_${PN}-dev += " \
+    ${datadir}/agl-compositor/protocols/agl-shell.xml \
+    ${datadir}/agl-compositor/protocols/agl-shell-desktop.xml \
+"