Remove usage of AGL_APP_REVISION 83/27783/3
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 21 Jul 2022 08:51:35 +0000 (10:51 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 21 Jul 2022 20:14:21 +0000 (20:14 +0000)
The floating AGL_APP_REVISION leads to more rebuilds than necessary.
Replace it with a fixed SRCREV. This is recommended by upstream YP.

Bug-AGL: SPEC-4481
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: Iea6a21720b920c5886c933c4ebc81856416368aa
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27783
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-agl-core/conf/distro/poky-agl.conf
meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb

index a719823..be6d77f 100644 (file)
@@ -11,20 +11,16 @@ AGL_BRANCH = "marlin"
 AGLVERSION = "13.0.1"
 # switch  devel/release
 AGLRELEASETYPE ?= "agldevelopment"
-#AGLRELEASETYPE ?= "aglrelease"
+#AGLRELEASETYPE := "aglrelease"
 OVERRIDES .= ":${AGLRELEASETYPE}"
 #
 
 #for development
 DISTRO_VERSION:agldevelopment := "${AGLVERSION}+snapshot-${DATE}"
-AGL_APP_REVISION:agldevelopment = "${AUTOREV}"
-AGL_DEFAULT_REVISION:agldevelopment = "${AUTOREV}"
 
 #for release
 DISTRO_VERSION:aglrelease := "${AGLVERSION}"
 DISTRO_BRANCH_VERSION_TAG = "${DISTRO_CODENAME}/${@'${DISTRO_VERSION}'.replace('+snapshot-${DATE}','')}"
-AGL_APP_REVISION:aglrelease := "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
-AGL_DEFAULT_REVISION:aglrelease := "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
 
 # reproducible builds:
 # enable the flag
index 70af49b..33276b9 100644 (file)
@@ -15,7 +15,7 @@ PV      = "1.0+git${SRCPV}"
 SRC_URI = " \
         git://gerrit.automotivelinux.org/gerrit/src/applaunchd;protocol=https;branch=${AGL_BRANCH}  \
         "
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "770cda52bb61ac93dfaf8cf58fc3f8a84f629976"
 
 S       = "${WORKDIR}/git"