qtwayland_%.bbappend: Force resize after buffer swap 02/24502/4
authorMarius Vlad <marius.vlad@collabora.com>
Tue, 12 May 2020 11:08:03 +0000 (14:08 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 17 May 2020 15:57:44 +0000 (15:57 +0000)
As the qtwayland client will sometimes 'forget' to do a redraw when
resizing back to the original geometry force it to happen each time at
the end of the EGL buffer swap. Temporary fix until a proper one is done
inside qtwayland.

Bug-SPEC: SPEC-3334

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: Iabf53065222a5ee803baf8ed146a11dd24a96860

meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend

index 408b2b6..6472c7e 100644 (file)
@@ -31,4 +31,5 @@ QT_SHELL_FILE = "${AFM_CONF_DIR}/qt-shell"
 do_install_append_class-target() {
        mkdir -p ${AFM_CONF_DIR}
        echo "QT_WAYLAND_SHELL_INTEGRATION=${DEFAULT_WM_SHELL}" > ${QT_SHELL_FILE}
+       echo "QT_WAYLAND_RESIZE_AFTER_SWAP=1" >> ${QT_SHELL_FILE}
 }