rpm: carry local PACKAGECONFIG fix for selinux
authorDenys Dmytriyenko <denys@konsulko.com>
Thu, 8 Feb 2024 02:16:45 +0000 (21:16 -0500)
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>
Thu, 7 Mar 2024 12:55:01 +0000 (12:55 +0000)
Can be dropped once the fix is accepted upstream:
https://patchwork.yoctoproject.org/project/yocto/patch/20240207210405.500713-1-denis@denix.org/

Change-Id: Ia18011145d4fec2c3e3ac59349f60b139068ce63
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
meta-agl-core/recipes-devtools/rpm/rpm_4.19%.bbappend [new file with mode: 0644]
meta-agl-core/recipes-devtools/rpm/rpm_aglcore.inc [new file with mode: 0644]

diff --git a/meta-agl-core/recipes-devtools/rpm/rpm_4.19%.bbappend b/meta-agl-core/recipes-devtools/rpm/rpm_4.19%.bbappend
new file mode 100644 (file)
index 0000000..9807832
--- /dev/null
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'aglcore', '${BPN}_aglcore.inc', '', d)}
diff --git a/meta-agl-core/recipes-devtools/rpm/rpm_aglcore.inc b/meta-agl-core/recipes-devtools/rpm/rpm_aglcore.inc
new file mode 100644 (file)
index 0000000..4997db9
--- /dev/null
@@ -0,0 +1,3 @@
+# new rpm 4.19 in OE-Core/Poky uses CMake instead of autoconf, update
+# selinux PACKAGECONFIG until meta-selinux catches up
+PACKAGECONFIG[selinux] = "-DWITH_SELINUX=ON,-DWITH_SELINUX=OFF,libselinux"