Support wayland/weson with GSES on emulated machine, QEMU(x86-64)
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Wed, 22 Jul 2015 01:53:24 +0000 (10:53 +0900)
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Wed, 22 Jul 2015 01:53:24 +0000 (10:53 +0900)
To boot weston image on emulated machine QEMU, a new sub-layer
`meta-agl-bsp` is added.

When bitbake agl-image-weston or agl-image-ivi With this layer,
weston GLES can run on QEMU with GLES support.

Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
meta-agl-bsp/conf/layer.conf [new file with mode: 0644]
meta-agl-bsp/recipes-graphics/mesa/mesa_10.%.bbappend [new file with mode: 0644]
meta-agl-bsp/recipes-graphics/wayland/weston_1.5.0.bbappend [new file with mode: 0644]

diff --git a/meta-agl-bsp/conf/layer.conf b/meta-agl-bsp/conf/layer.conf
new file mode 100644 (file)
index 0000000..b0010f7
--- /dev/null
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH =. "${LAYERDIR}:"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+            ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "aglbsp"
+BBFILE_PATTERN_aglbsp = "^${LAYERDIR}/"
+BBFILE_PRIORITY_aglbsp = "7"
diff --git a/meta-agl-bsp/recipes-graphics/mesa/mesa_10.%.bbappend b/meta-agl-bsp/recipes-graphics/mesa/mesa_10.%.bbappend
new file mode 100644 (file)
index 0000000..2561585
--- /dev/null
@@ -0,0 +1 @@
+PACKAGECONFIG_append = " gallium gallium-egl gallium-llvm"
diff --git a/meta-agl-bsp/recipes-graphics/wayland/weston_1.5.0.bbappend b/meta-agl-bsp/recipes-graphics/wayland/weston_1.5.0.bbappend
new file mode 100644 (file)
index 0000000..ce963ea
--- /dev/null
@@ -0,0 +1,14 @@
+RDEPENDS_${PN}_append = " libegl-gallium llvm3.3 "
+
+EXTRA_OECONF_append_vexpressa9 = "\
+    --enable-simple-egl-clients  \
+    WESTON_NATIVE_BACKEND=fbdev-backend.so \
+    "
+EXTRA_OECONF_append_qemux86 = "\
+    --enable-simple-egl-clients  \
+    WESTON_NATIVE_BACKEND=fbdev-backend.so \
+    "
+EXTRA_OECONF_append_qemux86-64 = "\
+    --enable-simple-egl-clients  \
+    WESTON_NATIVE_BACKEND=fbdev-backend.so \
+    "