[RCAR] Add missing dependency on wayland 24/26824/2
authorRonan Le Martret <ronan.lemartret@iot.bzh>
Tue, 21 Sep 2021 07:34:09 +0000 (09:34 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 9 Nov 2021 15:43:05 +0000 (15:43 +0000)
* Previous RCAR BSP provides lib /usr/lib/libpvrWAYLAND_WSEGL.so inside
  package gles-user-module. Now libpvrWAYLAND_WSEGL.so is in an independent
  package name wayland-wsegl.

Bug-AGL: SPEC-4081

Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Change-Id: I6bb80d44fd26d25aca860976575d45e65688b6cd
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26824
Reviewed-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend

index 707778c..ab59db6 100644 (file)
@@ -1,5 +1,7 @@
 require checksum_control.inc
 
+RDEPENDS_${PN}_append = " wayland-wsegl"
+
 do_install_append(){
         sed -i 's/MODE="0660", OWNER/MODE="0660", SECLABEL{smack}="*", OWNER/g' ${D}${sysconfdir}/udev/rules.d/72-pvr-seat.rules 
         sed -i 's/GROUP="video"/GROUP="display"/g' ${D}${sysconfdir}/udev/rules.d/72-pvr-seat.rules