Remove unnecessary group change at meta-agl-bsp for R-Car 90/28890/2
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Sat, 13 May 2023 15:07:13 +0000 (00:07 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 29 May 2023 13:35:52 +0000 (13:35 +0000)
Current AGL run each process by agl-driver user, that user
need access permission for GPU.  The old AGL use display
group to accept access for GPU, but current agl-driver
user join to video group that is default group for GPU.

This patch remove unnecessary group change at
meta-agl-bsp for R-Car.

Bug-AGL : SPEC-4797

Change-Id: Ife20dea685035b336675304a5c6fc292ed83deb6
Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28890
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend

index e191617..d6b220e 100644 (file)
@@ -3,8 +3,6 @@ require checksum_control.inc
 RDEPENDS:${PN}:append = " wayland-wsegl"
 
 do_install:append(){
-    sed -i 's/GROUP="video"/GROUP="display"/g' ${D}${sysconfdir}/udev/rules.d/72-pvr-seat.rules
-
     # Work around upstream not using ${nonarch_base_libdir}/firmware
     if ${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', 'true', 'false', d)}; then
         install -d ${D}${nonarch_base_libdir}/